summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-01-05 11:39:48 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-01-05 11:57:54 -0800
commit9021cdfa7682bdfebee8d612a2dbb1f33b60710b (patch)
treedfbc4e264b910177b2972ff0e935532f88f4728b /app-emulation/ganeti/files
parentnet-irc/irssi: security bump per upstream notification (diff)
downloadgentoo-9021cdfa7682bdfebee8d612a2dbb1f33b60710b.tar.gz
gentoo-9021cdfa7682bdfebee8d612a2dbb1f33b60710b.tar.bz2
gentoo-9021cdfa7682bdfebee8d612a2dbb1f33b60710b.zip
app-emulation/ganeti: version bump for early testing (not production usage)
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-emulation/ganeti/files')
-rw-r--r--app-emulation/ganeti/files/fix_ftbfs_with_sphinx_1.447
-rw-r--r--app-emulation/ganeti/files/ganeti-2.16-kvmd-run-as-daemon-user.patch30
-rw-r--r--app-emulation/ganeti/files/ganeti-2.16-noded-must-run-as-root.patch26
-rw-r--r--app-emulation/ganeti/files/ganeti-2.17-relax-deps.patch21
4 files changed, 124 insertions, 0 deletions
diff --git a/app-emulation/ganeti/files/fix_ftbfs_with_sphinx_1.4 b/app-emulation/ganeti/files/fix_ftbfs_with_sphinx_1.4
new file mode 100644
index 000000000000..0050203bf223
--- /dev/null
+++ b/app-emulation/ganeti/files/fix_ftbfs_with_sphinx_1.4
@@ -0,0 +1,47 @@
+Copied from 2.15.2 Debian Patches, as it was missed in the 2.16.0~rc1 debian patches.
+
+Author: Apollon Oikonomopoulos <apoikos@debian.org>
+Description: Fix FTBFS with sphinx 1.4
+ Suppress app.add_role warnings, as upstream knowingly overrides sphinx's
+ built-in manpage role. Without this, a warning is emitted which then turns to
+ an error when sphinx is run with the `-W' switch.
+ .
+ Also replace unicode ellipses in doc/design-query2.rst with three ascii dots,
+ as sphinx emits another warning for not being able to properly highlight these
+ lines as Python code.
+Last-Update: 2016-07-09
+Forwarded: no
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -229,3 +229,8 @@
+
+ # If false, no module index is generated.
+ latex_use_modindex = False
++
++# We override the manpage role and sphinx issues a warning, which is treated as
++# error. Suppress role_add warnings to avoid FTBFS.
++
++suppress_warnings = ["app.add_role"]
+--- a/doc/design-query2.rst
++++ b/doc/design-query2.rst
+@@ -129,16 +129,16 @@
+ specific names, the filter must be specified as follows, with the
+ inner part repeated for each name::
+
+- ["|", ["=", "name", "node1"], ["=", "name", "node2"], …]
++ ["|", ["=", "name", "node1"], ["=", "name", "node2"], ...]
+
+- Filters consist of S-expressions (``["operator", <operants…>]``) and
++ Filters consist of S-expressions (``["operator", <operants...>]``) and
+ extensions will be made in the future to allow for more operators and
+ fields. Such extensions might include a Python-style "in" operator,
+ but for simplicity only "=" is supported in this implementation.
+
+ To reiterate: Filters for this implementation must consist of exactly
+- one OR expression (``["|", …]``) and one or more name equality filters
+- (``["=", "name", "…"]``).
++ one OR expression (``["|", ...]``) and one or more name equality filters
++ (``["=", "name", "..."]``).
+
+ Support for synchronous queries, currently available in the interface
+ but disabled in the master daemon, will be dropped. Direct calls to
diff --git a/app-emulation/ganeti/files/ganeti-2.16-kvmd-run-as-daemon-user.patch b/app-emulation/ganeti/files/ganeti-2.16-kvmd-run-as-daemon-user.patch
new file mode 100644
index 000000000000..d74a6ca59b50
--- /dev/null
+++ b/app-emulation/ganeti/files/ganeti-2.16-kvmd-run-as-daemon-user.patch
@@ -0,0 +1,30 @@
+--- ganeti-2.16.0~rc1.orig/Makefile.am 2017-01-05 10:09:56.568213273 -0800
++++ ganeti-2.16.0~rc1/Makefile.am 2017-01-05 10:10:51.260260697 -0800
+@@ -2477,6 +2477,7 @@
+ echo 's#@''PKGLIBDIR@#$(libdir)/ganeti#g'; \
+ echo 's#@''GNTMASTERUSER@#$(MASTERD_USER)#g'; \
+ echo 's#@''GNTRAPIUSER@#$(RAPI_USER)#g'; \
++ echo 's#@''GNTKVMDUSER@#$(KVMD_USER)#g'; \
+ echo 's#@''GNTCONFDUSER@#$(CONFD_USER)#g'; \
+ echo 's#@''GNTWCONFDUSER@#$(WCONFD_USER)#g'; \
+ echo 's#@''GNTLUXIDUSER@#$(LUXID_USER)#g'; \
+@@ -2484,6 +2485,7 @@
+ echo 's#@''GNTMONDUSER@#$(MOND_USER)#g'; \
+ echo 's#@''GNTMETADUSER@#$(METAD_USER)#g'; \
+ echo 's#@''GNTRAPIGROUP@#$(RAPI_GROUP)#g'; \
++ echo 's#@''GNTKVMDGROUP@#$(KVMD_GROUP)#g'; \
+ echo 's#@''GNTADMINGROUP@#$(ADMIN_GROUP)#g'; \
+ echo 's#@''GNTCONFDGROUP@#$(CONFD_GROUP)#g'; \
+ echo 's#@''GNTNODEDGROUP@#$(NODED_GROUP)#g'; \
+--- ganeti-2.16.0~rc1.orig/daemons/daemon-util.in 2017-01-05 10:09:56.450211013 -0800
++++ ganeti-2.16.0~rc1/daemons/daemon-util.in 2017-01-05 10:11:17.804769059 -0800
+@@ -103,6 +103,9 @@
+ rapi)
+ echo "@GNTRAPIUSER@:@GNTRAPIGROUP@"
+ ;;
++ kvmd)
++ echo "@GNTKVMDUSER@:@GNTKVMDGROUP@"
++ ;;
+ noded)
+ echo "@GNTNODEDUSER@:@GNTNODEDGROUP@"
+ ;;
diff --git a/app-emulation/ganeti/files/ganeti-2.16-noded-must-run-as-root.patch b/app-emulation/ganeti/files/ganeti-2.16-noded-must-run-as-root.patch
new file mode 100644
index 000000000000..d6c440b51ee6
--- /dev/null
+++ b/app-emulation/ganeti/files/ganeti-2.16-noded-must-run-as-root.patch
@@ -0,0 +1,26 @@
+--- ganeti-2.16.0~rc1.orig/configure.ac 2017-01-05 10:09:56.480211588 -0800
++++ ganeti-2.16.0~rc1/configure.ac 2017-01-05 10:15:34.462684390 -0800
+@@ -380,9 +380,9 @@
+ group_luxid="${withval}luxid";
+ group_masterd="${withval}masterd";
+ group_metad="${withval}metad";
+- group_noded="$group_default";
++ group_noded="root";
+ group_daemons="${withval}daemons";
+- group_mond="$group_default"],
++ group_mond="root"],
+ [group_rapi="$group_default";
+ group_admin="$group_default";
+ group_confd="$group_default";
+@@ -391,9 +391,9 @@
+ group_luxid="$group_default";
+ group_masterd="$group_default";
+ group_metad="$group_default";
+- group_noded="$group_default";
++ group_noded="root";
+ group_daemons="$group_default";
+- group_mond="$group_default"])
++ group_mond="root"])
+ AC_SUBST(RAPI_GROUP, $group_rapi)
+ AC_SUBST(ADMIN_GROUP, $group_admin)
+ AC_SUBST(CONFD_GROUP, $group_confd)
diff --git a/app-emulation/ganeti/files/ganeti-2.17-relax-deps.patch b/app-emulation/ganeti/files/ganeti-2.17-relax-deps.patch
new file mode 100644
index 000000000000..ef4be0869560
--- /dev/null
+++ b/app-emulation/ganeti/files/ganeti-2.17-relax-deps.patch
@@ -0,0 +1,21 @@
+--- ganeti-2.17.0~beta1/cabal/ganeti.template.cabal 2017-01-05 10:29:49.936067812 -0800
++++ ganeti-2.17.0~beta1/cabal/ganeti.template.cabal 2017-01-05 10:33:03.248770000 -0800
+@@ -54,15 +54,15 @@
+ , transformers >= 0.3.0.0
+ , unix >= 2.5.1.0
+
+- , attoparsec >= 0.10.1.1 && < 0.13
++ , attoparsec >= 0.10.1.1 && < 0.14
+ , base64-bytestring >= 1.0.0.1 && < 1.1
+ , case-insensitive >= 0.4.0.1 && < 1.3
+ , Crypto >= 4.2.4 && < 4.3
+ , curl >= 1.3.7 && < 1.4
+ , hinotify >= 0.3.2 && < 0.4
+ , hslogger >= 1.1.4 && < 1.3
+- , json >= 0.5 && < 1.0
+- , lens >= 3.10 && < 4.13
++ , json >= 0.5
++ , lens >= 3.10
+ , lifted-base >= 0.2.0.3 && < 0.3
+ , monad-control >= 0.3.1.3 && < 1.1
+ , MonadCatchIO-transformers >= 0.3.0.0 && < 0.4