summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2016-05-12 16:24:52 -0700
committerPatrick McLean <chutzpah@gentoo.org>2016-05-12 16:24:52 -0700
commit95bea832acf85cc697689d9afad274c96e164635 (patch)
tree1d01429a9100b7c1d2cd46cd5c8a8f8bebc44c5d /app-emulation/ganeti/ganeti-2.12.3-r2.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.1.24 (diff)
downloadgentoo-95bea832acf85cc697689d9afad274c96e164635.tar.gz
gentoo-95bea832acf85cc697689d9afad274c96e164635.tar.bz2
gentoo-95bea832acf85cc697689d9afad274c96e164635.zip
app-emulation/ganeti: Remove use in global scope (bug #566524)
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/ganeti/ganeti-2.12.3-r2.ebuild')
-rw-r--r--app-emulation/ganeti/ganeti-2.12.3-r2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-emulation/ganeti/ganeti-2.12.3-r2.ebuild b/app-emulation/ganeti/ganeti-2.12.3-r2.ebuild
index 7707e09208c4..7c960a5f21b6 100644
--- a/app-emulation/ganeti/ganeti-2.12.3-r2.ebuild
+++ b/app-emulation/ganeti/ganeti-2.12.3-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=(python2_7)
-use test && PYTHON_REQ_USE="ipv6"
+PYTHON_REQ_USE="ipv6(+)?"
inherit eutils user autotools bash-completion-r1 python-single-r1 versionator
@@ -34,7 +34,9 @@ HOMEPAGE="http://www.ganeti.org/"
LICENSE="GPL-2"
SLOT="0"
IUSE="drbd haskell-daemons htools ipv6 kvm lxc monitoring multiple-users rbd syslog test xen"
-REQUIRED_USE="|| ( kvm xen lxc ) ${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="|| ( kvm xen lxc )
+ test? ( ipv6 )
+ ${PYTHON_REQUIRED_USE}"
USER_PREFIX="${GANETI_USER_PREFIX:-"gnt-"}"
GROUP_PREFIX="${GANETI_GROUP_PREFIX:-"${USER_PREFIX}"}"