summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2017-08-05 18:34:14 +0200
committerEttore Di Giacinto <mudler@gentoo.org>2017-09-04 22:45:11 +0200
commit433976df998e04d0b4d31038904007e7b5daccde (patch)
tree343ff653d9121f354efcc2ed871796a7b5e90345 /app-emulation/genymotion-bin
parentdev-db/sqlcl-bin: drop old (diff)
downloadgentoo-433976df998e04d0b4d31038904007e7b5daccde.tar.gz
gentoo-433976df998e04d0b4d31038904007e7b5daccde.tar.bz2
gentoo-433976df998e04d0b4d31038904007e7b5daccde.zip
app-emulation/genymotion-bin: version bump to 2.10.0
Package-Manager: Portage-2.3.6, Repoman-2.3.1 Signed-off-by: Ettore Di Giacinto <mudler@gentoo.org>
Diffstat (limited to 'app-emulation/genymotion-bin')
-rw-r--r--app-emulation/genymotion-bin/Manifest1
-rw-r--r--app-emulation/genymotion-bin/genymotion-bin-2.10.0.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/app-emulation/genymotion-bin/Manifest b/app-emulation/genymotion-bin/Manifest
index 2f435a8ce5f6..7cf888d100de 100644
--- a/app-emulation/genymotion-bin/Manifest
+++ b/app-emulation/genymotion-bin/Manifest
@@ -1 +1,2 @@
+DIST genymotion-2.10.0-linux_x64.bin 44847023 SHA256 558d9faf96780ddd972b7769d0e3871b71cdbc104c291d40b0be0092607dec60 SHA512 fe89376a48121b9c3cb1392d7365e13ee2865b795b1d8712e3461072bd0e0d38fd309814d7ecd5518fe2673229fb2e49b4c239211f4308f1057f3d01052d4007 WHIRLPOOL fea75a4d17bdb158316024db2b6d3f2e6e370595602b58fb7f38aa6a0bb91f0c11974548a5d2790179d139a374f515355f1e564de0e5a704afe0255b78e15509
DIST genymotion-2.9.0-linux_x64.bin 44858494 SHA256 2392c8fdce45354d109b001e72d994f26bd6d4a3976ef91f02404178dc66c110 SHA512 cf96b804ecfb5c620d20ce601ab6a99bdcc9365efa9bf6e830ac54c75ad2838372115db425a549b89a05bc496ce39dbb51a3abeba1641e300f801f996eeaaf1f WHIRLPOOL 49b2abe0f04b34810140410deac8a0063787963828186b97bc595da94686b50b46c5c7422dcc4bb49b26eb8cf438e696914f11fd0bb37f0830731781bfe401d8
diff --git a/app-emulation/genymotion-bin/genymotion-bin-2.10.0.ebuild b/app-emulation/genymotion-bin/genymotion-bin-2.10.0.ebuild
new file mode 100644
index 000000000000..60d6d52b290a
--- /dev/null
+++ b/app-emulation/genymotion-bin/genymotion-bin-2.10.0.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils bash-completion-r1 pax-utils
+
+MY_PN="${PN/-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Complete set of tools that provide a virtual environment for Android"
+HOMEPAGE="http://genymotion.com"
+SRC_URI="${MY_P}-linux_x64.bin"
+DOWNLOAD_URL="https://www.genymotion.com/download/"
+
+LICENSE="genymotion"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+DEPEND=""
+RDEPEND="|| ( >=app-emulation/virtualbox-5.0.28 >=app-emulation/virtualbox-bin-5.0.28 )
+ virtual/opengl
+ dev-libs/openssl
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwebkit:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtsvg:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgraphicaleffects:5
+ sys-apps/util-linux
+ media-libs/gst-plugins-base:0.10
+"
+# note if you compile protobuf with >=gcc-5.1 you need to disable the new c++11 abi
+# -D_GLIBCXX_USE_CXX11_ABI=0 to your CXXFLAGS for protobuf
+# =dev-libs/protobuf-2.6*
+
+RESTRICT="bindist fetch"
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo
+ einfo "Please visit ${DOWNLOAD_URL} and download ${A}"
+ einfo "which must be placed in DISTDIR directory."
+ einfo
+}
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" "${WORKDIR}" || die "cp failed"
+}
+
+src_prepare() {
+ default
+
+ # removed function _install_desktop_file because happens outside of sandbox
+ sed -i -e "s/_install_desktop_file\ ||\ abort//" ${A} || die "sed failed"
+ chmod +x ${A} || die "chmod failed"
+ yes | ./${A} -d "${S}" > /dev/null || die "unpack failed"
+
+ # removed windows line for bashcompletion
+ sed -i -e "s/complete\ -F\ _gmtool\ gmtool.exe//" "${S}/${MY_PN}/completion/bash/gmtool.bash" || die "sed failed"
+}
+
+QA_PREBUILT="
+ opt/${MY_PN}/*.so*
+ opt/${MY_PN}/imageformats/*.so
+ opt/${MY_PN}/plugins/*.so*
+ opt/${MY_PN}/device-upgrade
+ opt/${MY_PN}/${MY_PN}
+ opt/${MY_PN}/genyshell
+ opt/${MY_PN}/player
+ opt/${MY_PN}/${MY_PN}adbtunneld
+ opt/${MY_PN}/gmtool
+"
+
+src_install() {
+ insinto /opt/"${MY_PN}"
+ doins -r "${MY_PN}"/{plugins,translations,icons}
+
+ doins "${MY_PN}"/{libcom,librendering}.so*
+ # library that differ from system version
+ doins "${MY_PN}"/{libswscale,libavutil,libprotobuf}.so*
+ # android library
+ doins "${MY_PN}"/{libEGL_translator,libGLES_CM_translator,libGLES_V2_translator,libOpenglRender,libemugl_logger}.so*
+
+ insopts -m0755
+ doins "${MY_PN}"/{device-upgrade,genymotion,genyshell,player,genymotionadbtunneld,gmtool}
+
+ pax-mark -m "${ED%/}/opt/${MY_PN}/${MY_PN}"
+ pax-mark -m "${ED%/}/opt/${MY_PN}/gmtool"
+
+ dosym "${ED%/}"/opt/"${MY_PN}"/genyshell /opt/bin/genyshell
+ dosym "${ED%/}"/opt/"${MY_PN}"/"${MY_PN}" /opt/bin/"${MY_PN}"
+ dosym "${ED%/}"/opt/"${MY_PN}"/gmtool /opt/bin/gmtool
+
+ # Workaround
+ dosym "${ED%/}/"usr/$(get_libdir)/qt5/plugins/imageformats/libqsvg.so /opt/"${MY_PN}"/imageformats/libqsvg.so
+ dosym "${ED%/}/"usr/$(get_libdir)/qt5/plugins/sqldrivers/libqsqlite.so /opt/"${MY_PN}"/sqldrivers/libqsqlite.so
+
+ newbashcomp "${MY_PN}/completion/bash/gmtool.bash" gmtool
+
+ if has_version "app-shells/zsh" ; then
+ insinto /usr/share/zsh/site-functions
+ doins "${MY_PN}/completion/zsh/_gmtool"
+ fi
+
+ make_desktop_entry "/opt/${MY_PN}/${MY_PN}" "Genymotion ${PV}" "/opt/${MY_PN}/icons/icon.png" "Development;Emulator;"
+ mv "${ED%/}"/usr/share/applications/*.desktop "${ED%/}"/usr/share/applications/"${MY_PN}".desktop || die "mv failed"
+}
+
+pkg_postinst() {
+ elog "Genymotion needs adb to work correctly: install with android-sdk-update-manager"
+ elog "'Android SDK Platform-tools' and 'Android SDK Tools'"
+ elog "Your user should also be in the android group to work correctly"
+ elog "Then in Genymotion set the android-sdk-update-manager directory: (Settings->ADB)"
+ elog
+ elog " /opt/android-sdk-update-manager"
+}