summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-03-20 09:25:57 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-03-20 09:26:25 +0300
commitc80fe4a45d496ee919fbef2e16a7f341b0e9cdfa (patch)
tree256cb1ab1062b4798a881a77040daa2c8a6bad95 /app-emulation/glean
parentdev-ruby/semantic_puppet: add 1.0.2 (diff)
downloadgentoo-c80fe4a45d496ee919fbef2e16a7f341b0e9cdfa.tar.gz
gentoo-c80fe4a45d496ee919fbef2e16a7f341b0e9cdfa.tar.bz2
gentoo-c80fe4a45d496ee919fbef2e16a7f341b0e9cdfa.zip
app-emulation/glean: Initial import
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emulation/glean')
-rw-r--r--app-emulation/glean/Manifest1
-rw-r--r--app-emulation/glean/files/glean.initd15
-rw-r--r--app-emulation/glean/glean-1.10.3.ebuild27
-rw-r--r--app-emulation/glean/metadata.xml19
4 files changed, 62 insertions, 0 deletions
diff --git a/app-emulation/glean/Manifest b/app-emulation/glean/Manifest
new file mode 100644
index 000000000000..e9f14177af8b
--- /dev/null
+++ b/app-emulation/glean/Manifest
@@ -0,0 +1 @@
+DIST glean-1.10.3.tar.gz 51898 BLAKE2B 95bcee5caae1bdcdc586c8d8ab8097b1dfaa35c521d7b90d128db14f496d4d31e1d0d4c540c4205861e5c7fa87d0e7038227ae9db0e898e3bf43b8b9b989e766 SHA512 27d4f29bf35585f73813e9efdea0253f0be3a8fa059c6ce524fbdd37b865d9c9e10d29bb8f970317ffe772c110cc76f10ae7debce5f7433461639dc63b9349db
diff --git a/app-emulation/glean/files/glean.initd b/app-emulation/glean/files/glean.initd
new file mode 100644
index 000000000000..16f7805957f2
--- /dev/null
+++ b/app-emulation/glean/files/glean.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+
+description="Simple program to write static config from config-drive"
+
+depend() {
+ need root localmount
+ before net
+}
+
+start() {
+ ebegin "Starting Glean"
+ /usr/bin/glean.sh
+ eend
+}
diff --git a/app-emulation/glean/glean-1.10.3.ebuild b/app-emulation/glean/glean-1.10.3.ebuild
new file mode 100644
index 000000000000..51ca92a7a2a4
--- /dev/null
+++ b/app-emulation/glean/glean-1.10.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple program to write static config from config-drive"
+HOMEPAGE="https://github.com/openstack-infra/glean"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
diff --git a/app-emulation/glean/metadata.xml b/app-emulation/glean/metadata.xml
new file mode 100644
index 000000000000..5f29d506900e
--- /dev/null
+++ b/app-emulation/glean/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ Glean is a program intended to configure a system based on configuration provided in a configuration drive.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">glean</remote-id>
+ <remote-id type="github">openstack-dev/glean</remote-id>
+ </upstream>
+</pkgmetadata>