summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2018-11-23 08:49:56 +0100
committerTiziano Müller <dev-zero@gentoo.org>2018-11-23 08:51:23 +0100
commit2084875d5ddd01a0efb61a5d18aff9bb049ff6d5 (patch)
treea297587c8e40f2b53321a9cfd4d15f94d6da6184 /app-emulation/libcacard/libcacard-2.6.0.ebuild
parentsys-apps/opentmpfiles: mark latest stable (diff)
downloadgentoo-2084875d5ddd01a0efb61a5d18aff9bb049ff6d5.tar.gz
gentoo-2084875d5ddd01a0efb61a5d18aff9bb049ff6d5.tar.bz2
gentoo-2084875d5ddd01a0efb61a5d18aff9bb049ff6d5.zip
app-emulation/libcacard: fix test failures
by reducing the test suite for now to avoid pulling in SoftHSMv2 Closes: https://bugs.gentoo.org/663704 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tiziano Müller <dev-zero@gentoo.org>
Diffstat (limited to 'app-emulation/libcacard/libcacard-2.6.0.ebuild')
-rw-r--r--app-emulation/libcacard/libcacard-2.6.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-emulation/libcacard/libcacard-2.6.0.ebuild b/app-emulation/libcacard/libcacard-2.6.0.ebuild
index 22750df56b3f..39e02adda5a7 100644
--- a/app-emulation/libcacard/libcacard-2.6.0.ebuild
+++ b/app-emulation/libcacard/libcacard-2.6.0.ebuild
@@ -18,6 +18,15 @@ RDEPEND=">=dev-libs/nss-3.13
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ default
+
+ # remove test requiring SoftHSMv2 which is not in the tree atm
+ sed -i \
+ -e 's|tests/hwtests$(EXEEXT) \($(am__EXEEXT_1)\)|\1|' \
+ Makefile.in || die
+}
+
src_configure() {
econf \
$(use_enable passthrough pcsc) \