summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-07 15:42:27 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-07 17:24:37 +0100
commit4a4bf33bb6f22f213e03942306ebba47fc9edc23 (patch)
tree1b19b827877756aea694c6ba476ac9ed7a59a31b /app-emulation/libguestfs-appliance/libguestfs-appliance-1.38.0.ebuild
parentmedia-sound/snapcast: USE flag avahi > zeroconf (diff)
downloadgentoo-4a4bf33bb6f22f213e03942306ebba47fc9edc23.tar.gz
gentoo-4a4bf33bb6f22f213e03942306ebba47fc9edc23.tar.bz2
gentoo-4a4bf33bb6f22f213e03942306ebba47fc9edc23.zip
app-emulation/libguestfs-appliance: 1.36.1 → 1.38.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'app-emulation/libguestfs-appliance/libguestfs-appliance-1.38.0.ebuild')
-rw-r--r--app-emulation/libguestfs-appliance/libguestfs-appliance-1.38.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/libguestfs-appliance/libguestfs-appliance-1.38.0.ebuild b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.38.0.ebuild
new file mode 100644
index 000000000000..31e8b16bfd51
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.38.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+CHECKREQS_DISK_USR=500M
+CHECKREQS_DISK_BUILD=500M
+
+inherit check-reqs
+
+DESCRIPTION="VM appliance disk image used in libguestfs package"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/binaries/appliance/appliance-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+# Mixing libguestfs versions causes weird problems. #501588
+RDEPEND="!<app-emulation/libguestfs-${PV}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # We'll unpack the tarball directly into ${D} to speed up install.
+ # Otherwise we need to duplicate hundreds of data.
+ :
+}
+
+src_install() {
+ dodir /usr/share/guestfs
+ cd "${ED}"/usr/share/guestfs
+ unpack ${A}
+ cd appliance || die
+ dodoc README*
+ # Don't rm README.* here, at least README.fixed is needed for libguestfs, see
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1183780
+ chmod 755 . || die
+ chmod 644 * || die
+
+ newenvd "${FILESDIR}"/env.file 99"${PN}"
+}