summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-11-25 20:25:06 -0800
committerZac Medico <zmedico@gentoo.org>2019-11-25 20:25:06 -0800
commit43305c9e8e3c9f4b2f86d053381a7b9ba5bd4d77 (patch)
treee6a312275d66594c4f6ee39f47f1e1d235335d9d /app-emulation/libpod
parentapp-emulation/buildah: add upstream VFS user xattrs patch (diff)
downloadgentoo-43305c9e8e3c9f4b2f86d053381a7b9ba5bd4d77.tar.gz
gentoo-43305c9e8e3c9f4b2f86d053381a7b9ba5bd4d77.tar.bz2
gentoo-43305c9e8e3c9f4b2f86d053381a7b9ba5bd4d77.zip
app-emulation/libpod: add upstream VFS user xattrs patch
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/libpod')
-rw-r--r--app-emulation/libpod/Manifest1
-rw-r--r--app-emulation/libpod/libpod-1.6.3-r2.ebuild (renamed from app-emulation/libpod/libpod-1.6.3-r1.ebuild)8
2 files changed, 8 insertions, 1 deletions
diff --git a/app-emulation/libpod/Manifest b/app-emulation/libpod/Manifest
index 65cc6cd084c0..8ea0c53b5868 100644
--- a/app-emulation/libpod/Manifest
+++ b/app-emulation/libpod/Manifest
@@ -1 +1,2 @@
+DIST containers-storage-1.14.0-vfs-user-xattrs.patch 14835 BLAKE2B 99c35933dcb25385ee83b80cf282c11c738d0e4d91216cc08a50522f6caa9bca5938299412908f16df404f99e80616a10b4c02c0ebc38240a987830ddaf15008 SHA512 62c7ed49728bd12b5706f59b0d4af3b18d90e8cfc2b06e681f84fe3f5d3e0cd5c0317147109c4e3ec4fec26f82c269af3c9813e47339ce102e4e97400b74627d
DIST libpod-1.6.3.tar.gz 8340471 BLAKE2B b017a29ab034d8432b3abe2d920e0a71ad6542a5f088ed0de8fc67e846b409efbfd5be2e72908b52b5d21f05ce30c31db3bd55f8d8974711eb8f48cf8c3553a5 SHA512 a4d9f4c74db42fade86c36f4b2c27b8b3ff42db90af21bccab2eae8e9d710ae102c05e1fa926ac1d8e67613e11fa40163800077b61e49d90de521ab472e9c8dd
diff --git a/app-emulation/libpod/libpod-1.6.3-r1.ebuild b/app-emulation/libpod/libpod-1.6.3-r2.ebuild
index fbbde543c71c..f8dcfddf4ebd 100644
--- a/app-emulation/libpod/libpod-1.6.3-r1.ebuild
+++ b/app-emulation/libpod/libpod-1.6.3-r2.ebuild
@@ -9,7 +9,9 @@ inherit bash-completion-r1 flag-o-matic go-module
DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
HOMEPAGE="https://github.com/containers/libpod/"
-SRC_URI="https://github.com/containers/libpod/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+CONTAINERS_STORAGE_PATCH="containers-storage-1.14.0-vfs-user-xattrs.patch"
+SRC_URI="https://github.com/containers/libpod/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/containers/storage/pull/466.patch -> ${CONTAINERS_STORAGE_PATCH}"
LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
SLOT="0"
@@ -39,6 +41,10 @@ RDEPEND="${COMMON_DEPEND}"
src_prepare() {
default
+ sed -e 's| \([ab]\)/| \1/vendor/github.com/containers/storage/|' < \
+ "${DISTDIR}/${CONTAINERS_STORAGE_PATCH}" > \
+ "${WORKDIR}/${CONTAINERS_STORAGE_PATCH}" || die
+ eapply "${WORKDIR}/${CONTAINERS_STORAGE_PATCH}"
# Disable installation of python modules here, since those are
# installed by separate ebuilds.