summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-08-29 17:11:39 -0700
committerZac Medico <zmedico@gentoo.org>2020-08-29 17:12:51 -0700
commit88ea6439c00b87a2639a94f7245c3db6ee0bd0ff (patch)
tree17addb9863b59fd160b646862ba2b991b2f167da /app-emulation/libpod
parentnet-irc/sic: fix musl, clang builds (diff)
downloadgentoo-88ea6439c00b87a2639a94f7245c3db6ee0bd0ff.tar.gz
gentoo-88ea6439c00b87a2639a94f7245c3db6ee0bd0ff.tar.bz2
gentoo-88ea6439c00b87a2639a94f7245c3db6ee0bd0ff.zip
app-emulation/libpod: Bump to version 2.0.5
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/libpod')
-rw-r--r--app-emulation/libpod/Manifest1
-rw-r--r--app-emulation/libpod/libpod-2.0.5.ebuild154
2 files changed, 155 insertions, 0 deletions
diff --git a/app-emulation/libpod/Manifest b/app-emulation/libpod/Manifest
index 5dfdd29f2200..93c86fe3f2ae 100644
--- a/app-emulation/libpod/Manifest
+++ b/app-emulation/libpod/Manifest
@@ -5,3 +5,4 @@ DIST libpod-2.0.1.tar.gz 9136153 BLAKE2B 4c60dc047ae7fd6a2918589a30f6dc94c13251e
DIST podman-2.0.2.tar.gz 9192157 BLAKE2B b8635ea5b166082be03a041f74d6c7a5c8bed04131b039ba505f87240a1a2e4503a3dc14c037eeb41955ff7f949dc0978571ec63f011adb9e5a6efa1157b6bce SHA512 5bcdca28021c8b36b5689e69c00232ca20404af0903ea632cea350ecf6b6eed091260f1b8fea8fe6d06caa7a475ba87ef4f3e86e83807ffdd187f9ccc41cb194
DIST podman-2.0.3.tar.gz 9303421 BLAKE2B c0882c7fff60f33d1dc6752120a36ce35ce321c661ec29ae940f392b5ef9fb6176fea556a89ca9823b4981997d6e61545531d39d95b31d23602b0d3e1a78870a SHA512 ee6d4f4735196fc07e03e9c1e99aa62650d9651bd5f24657398d42b3f2ebf59240a49fecfbf71a3d90636ea44c243cc4f7504c43d8f48e76ee504b3d10762240
DIST podman-2.0.4.tar.gz 9305631 BLAKE2B a6a5760886d112b6cd69625137ec0aa9e368e8ff09f114123ff0b17ad2ef5b26b5eb645a5bbabc30a7cb900d7844587e0051969fefba9d5e8b5652a571857e09 SHA512 39313615b4c0befec3a073b7bf4a689208e39cb7bcba81f6d8982e188402c457cbe4835a128274761e55ab1272a780f9747caa07746fe62af7a568eebc96ad6a
+DIST podman-2.0.5.tar.gz 9338371 BLAKE2B 8bf86ac438c2a7c250d77df46d315dfa9d3326097a332e32de08b4d9acfeae9ace0b1825f242cddaf6178fd34d4c7542e9c59c4ce462525371c081b60cf0e9a7 SHA512 efe1bdfd1fec61d470c748ac1cfff8ec4a64a47751becac2c35d85e61f1f1d511781f4fafb3463558bd5df347f3ee021c4f9ed00823b6cb5dd8963a2c2bc570b
diff --git a/app-emulation/libpod/libpod-2.0.5.ebuild b/app-emulation/libpod/libpod-2.0.5.ebuild
new file mode 100644
index 000000000000..ae5e98e013ce
--- /dev/null
+++ b/app-emulation/libpod/libpod-2.0.5.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="776abc52106ec7652ced6dbc0869020123ed393d"
+
+inherit bash-completion-r1 flag-o-matic go-module
+
+DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
+HOMEPAGE="https://github.com/containers/podman/"
+MY_PN=podman
+MY_P=${MY_PN}-${PV}
+SRC_URI="https://github.com/containers/podman/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64"
+IUSE="apparmor btrfs +fuse +rootless selinux"
+RESTRICT="test"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ >=app-emulation/conmon-2.0.0
+ || ( >=app-emulation/runc-1.0.0_rc6 app-emulation/crun )
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ >=net-misc/cni-plugins-0.8.6
+ sys-fs/lvm2
+ sys-libs/libseccomp:=
+
+ apparmor? ( sys-libs/libapparmor )
+ btrfs? ( sys-fs/btrfs-progs )
+ rootless? ( app-emulation/slirp4netns )
+ selinux? ( sys-libs/libselinux:= )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}
+ fuse? ( sys-fs/fuse-overlayfs )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # Disable installation of python modules here, since those are
+ # installed by separate ebuilds.
+ local makefile_sed_args=(
+ -e '/^GIT_.*/d'
+ -e 's/$(GO) build/$(GO) build -v -work -x/'
+ -e 's/^\(install:.*\) install\.python$/\1/'
+ -e 's|^pkg/varlink/iopodman.go: .gopathok pkg/varlink/io.podman.varlink$|pkg/varlink/iopodman.go: pkg/varlink/io.podman.varlink|'
+ )
+
+ has_version -b '>=dev-lang/go-1.13.9' || makefile_sed_args+=(-e 's:GO111MODULE=off:GO111MODULE=on:')
+
+ sed "${makefile_sed_args[@]}" -i Makefile || die
+
+ sed -e 's|OUTPUT="${CIRRUS_TAG:.*|OUTPUT='v${PV}'|' \
+ -i hack/get_release_info.sh || die
+}
+
+src_compile() {
+ # Filter unsupported linker flags
+ filter-flags '-Wl,*'
+
+ [[ -f hack/apparmor_tag.sh ]] || die
+ if use apparmor; then
+ echo -e "#!/bin/sh\necho apparmor" > hack/apparmor_tag.sh || die
+ else
+ echo -e "#!/bin/sh\ntrue" > hack/apparmor_tag.sh || die
+ fi
+
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ if use btrfs; then
+ echo -e "#!/bin/sh\ntrue" > hack/btrfs_installed_tag.sh || die
+ else
+ echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die
+ fi
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ if use selinux; then
+ echo -e "#!/bin/sh\necho selinux" > hack/selinux_tag.sh || die
+ else
+ echo -e "#!/bin/sh\ntrue" > hack/selinux_tag.sh || die
+ fi
+
+ # Avoid this error when generating pkg/varlink/iopodman.go:
+ # cannot find package "github.com/varlink/go/varlink/idl"
+ mkdir -p _output || die
+ ln -snf ../vendor _output/src || die
+ GO111MODULE=off GOPATH=${PWD}/_output go generate ./pkg/varlink/... || die
+ rm _output/src || die
+
+ export -n GOCACHE GOPATH XDG_CACHE_HOME
+ GOBIN="${S}/bin" \
+ emake all \
+ GIT_BRANCH=master \
+ GIT_BRANCH_CLEAN=master \
+ COMMIT_NO="${EGIT_COMMIT}" \
+ GIT_COMMIT="${EGIT_COMMIT}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+ insinto /etc/containers
+ newins test/registries.conf registries.conf.example
+ newins test/policy.json policy.json.example
+
+ insinto /usr/share/containers
+ doins seccomp.json
+
+ newinitd "${FILESDIR}"/podman.initd podman
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/podman.logrotated" podman
+
+ dobashcomp completions/bash/*
+
+ keepdir /var/lib/containers
+}
+
+pkg_preinst() {
+ LIBPOD_ROOTLESS_UPGRADE=false
+ if use rootless; then
+ has_version 'app-emulation/libpod[rootless]' || LIBPOD_ROOTLESS_UPGRADE=true
+ fi
+}
+
+pkg_postinst() {
+ local want_newline=false
+ if [[ ! ( -e ${EROOT%/*}/etc/containers/policy.json && -e ${EROOT%/*}/etc/containers/registries.conf ) ]]; then
+ elog "You need to create the following config files:"
+ elog "/etc/containers/registries.conf"
+ elog "/etc/containers/policy.json"
+ elog "To copy over default examples, use:"
+ elog "cp /etc/containers/registries.conf{.example,}"
+ elog "cp /etc/containers/policy.json{.example,}"
+ want_newline=true
+ fi
+ if [[ ${LIBPOD_ROOTLESS_UPGRADE} == true ]] ; then
+ ${want_newline} && elog ""
+ elog "For rootless operation, you need to configure subuid/subgid"
+ elog "for user running podman. In case subuid/subgid has only been"
+ elog "configured for root, run:"
+ elog "usermod --add-subuids 1065536-1131071 <user>"
+ elog "usermod --add-subgids 1065536-1131071 <user>"
+ want_newline=true
+ fi
+}