summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-05-31 23:09:51 -0700
committerZac Medico <zmedico@gentoo.org>2019-05-31 23:09:51 -0700
commitbbc628ff2d2b878966df78fa0b4376b291e2cf32 (patch)
tree9b22593dca8bfbc0166065ff2ba98e83bc08e9fd /app-emulation/libpod
parentapp-emulation/conmon: add package (diff)
downloadgentoo-bbc628ff2d2b878966df78fa0b4376b291e2cf32.tar.gz
gentoo-bbc628ff2d2b878966df78fa0b4376b291e2cf32.tar.bz2
gentoo-bbc628ff2d2b878966df78fa0b4376b291e2cf32.zip
app-emulation/libpod: remove old versions
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/libpod')
-rw-r--r--app-emulation/libpod/Manifest2
-rw-r--r--app-emulation/libpod/libpod-1.1.2.ebuild139
-rw-r--r--app-emulation/libpod/libpod-1.2.0.ebuild139
3 files changed, 0 insertions, 280 deletions
diff --git a/app-emulation/libpod/Manifest b/app-emulation/libpod/Manifest
index 066e117c70a8..5f41cc0145c0 100644
--- a/app-emulation/libpod/Manifest
+++ b/app-emulation/libpod/Manifest
@@ -1,3 +1 @@
-DIST libpod-1.1.2.tar.gz 7878228 BLAKE2B 8974949843c6f966d48715df320e47b814e442e374e1393dd5a116c6f7222e9ce29f480205f6a58e213e6cead58e5b4f31fd776865911b22e517607349654d35 SHA512 55456fe03da0873d3f6c67ced25dbe98f6a5a14c3da64ab2b4a9c6161c1d727ec8cdfe5414b534531e440e8c86f909449f4026d66898b909924aba1744ec0682
-DIST libpod-1.2.0.tar.gz 7978520 BLAKE2B c1be831553ced9795de266886890c36e89f2b6c2012cbe4f36fa49194c3a825abc097af879326e8e1ad7886ea188d60c42fe1dfa1ad46057c5928f3b5c4f7cd4 SHA512 16ae8fa8a6e9a15d17f7aebe0842bf41e289cbbe5ea8e997c26b2d3e984d669386022e7d1479ca31e8cab8990ae4e2dc1cf753f010bf9aeb03a34199b1146e89
DIST libpod-1.3.2.tar.gz 6901289 BLAKE2B 5de0cf9f47f7e10866839ba01f3c3ed930ebdb716ce10ca4cb6f6b4d0e96088e10a069726125f2dc4af6febe08e6b2fc058fb8e8ecd7dd870612ecb98f29bba5 SHA512 fb959bf6af314baf3d01c53b513390b6d181adca3f9ff2ca747fabd53abdd45907e8a3f8189ff2d1bd70cff8e8bad690407cf278392a0831e6109669a1c1b12b
diff --git a/app-emulation/libpod/libpod-1.1.2.ebuild b/app-emulation/libpod/libpod-1.1.2.ebuild
deleted file mode 100644
index 0d80616d4c55..000000000000
--- a/app-emulation/libpod/libpod-1.1.2.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_COMMIT="0ad9b6bf2aea4ba37e8c9738feabec61343ba175"
-EGO_PN="github.com/containers/${PN}"
-
-inherit golang-vcs-snapshot systemd
-
-DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
-HOMEPAGE="https://github.com/containers/libpod/"
-SRC_URI="https://github.com/containers/libpod/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64"
-IUSE="apparmor btrfs ostree +rootless selinux"
-REQUIRED_USE="!selinux? ( !ostree )"
-RESTRICT="test"
-
-COMMON_DEPEND="
- app-crypt/gpgme:=
- >=app-emulation/cri-o-1.13.0
- >=app-emulation/runc-1.0.0_rc6
- dev-libs/libassuan:=
- dev-libs/libgpg-error:=
- sys-fs/lvm2
- sys-libs/libseccomp:=
-
- apparmor? ( sys-libs/libapparmor )
- btrfs? ( sys-fs/btrfs-progs )
- ostree? (
- dev-libs/glib:=
- dev-util/ostree:=
- )
- rootless? ( app-emulation/slirp4netns )
- selinux? ( sys-libs/libselinux:= )
-"
-DEPEND="
- ${COMMON_DEPEND}
- dev-go/go-md2man"
-RDEPEND="${COMMON_DEPEND}"
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-src_prepare() {
- default
-
- # Disable installation of python modules here, since those are
- # installed by separate ebuilds.
- sed -e '/^GIT_.*/d' \
- -e 's/$(GO) build/$(GO) build -v -work -x/' \
- -e 's/^\(install:.*\) install\.python$/\1/' \
- -i Makefile || die
-}
-
-src_compile() {
- [[ -f hack/apparmor_tag.sh ]] || die
- if use apparmor; then
- echo -e "#!/bin/sh\necho apparmor" > hack/apparmor_tag.sh || die
- else
- echo -e "#!/bin/sh\ntrue" > hack/apparmor_tag.sh || die
- fi
-
- [[ -f hack/btrfs_installed_tag.sh ]] || die
- if use btrfs; then
- echo -e "#!/bin/sh\ntrue" > hack/btrfs_installed_tag.sh || die
- else
- echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
- hack/btrfs_installed_tag.sh || die
- fi
-
- [[ -f hack/ostree_tag.sh ]] || die
- if use ostree; then
- echo -e "#!/bin/sh\necho ostree" > hack/ostree_tag.sh || die
- else
- echo -e "#!/bin/sh\necho containers_image_ostree_stub" > hack/ostree_tag.sh || die
- fi
-
- [[ -f hack/selinux_tag.sh ]] || die
- if use selinux; then
- echo -e "#!/bin/sh\necho selinux" > hack/selinux_tag.sh || die
- else
- echo -e "#!/bin/sh\ntrue" > hack/selinux_tag.sh || die
- fi
-
- env -u GOCACHE -u LDFLAGS -u XDG_CACHE_HOME GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
- emake all \
- GIT_BRANCH=master \
- GIT_BRANCH_CLEAN=master \
- COMMIT_NO="${EGIT_COMMIT}" \
- GIT_COMMIT="${EGIT_COMMIT}"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install
-
- insinto /etc/containers
- newins test/registries.conf registries.conf.example
- newins test/policy.json policy.json.example
-
- newinitd "${FILESDIR}"/podman.initd podman
-
- systemd_dounit "${S}"/contrib/varlink/*.service "${S}"/contrib/varlink/*.socket
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/podman.logrotated" podman
-
- keepdir /var/lib/containers
-}
-
-pkg_preinst() {
- LIBPOD_ROOTLESS_UPGRADE=false
- if use rootless; then
- has_version 'app-emulation/libpod[rootless]' || LIBPOD_ROOTLESS_UPGRADE=true
- fi
-}
-
-pkg_postinst() {
- local want_newline=false
- if [[ ! ( -e ${EROOT%/*}/etc/containers/policy.json && -e ${EROOT%/*}/etc/containers/registries.conf ) ]]; then
- elog "You need to create the following config files:"
- elog "/etc/containers/registries.conf"
- elog "/etc/containers/policy.json"
- elog "To copy over default examples, use:"
- elog "cp /etc/containers/registries.conf{.example,}"
- elog "cp /etc/containers/policy.json{.example,}"
- want_newline=true
- fi
- if [[ ${LIBPOD_ROOTLESS_UPGRADE} == true ]] ; then
- ${want_newline} && elog ""
- elog "For rootless operation, you need to configure subuid/subgid"
- elog "for user running podman. In case subuid/subgid has only been"
- elog "configured for root, run:"
- elog "usermod --add-subuids 1065536-1131071 <user>"
- elog "usermod --add-subgids 1065536-1131071 <user>"
- want_newline=true
- fi
-}
diff --git a/app-emulation/libpod/libpod-1.2.0.ebuild b/app-emulation/libpod/libpod-1.2.0.ebuild
deleted file mode 100644
index 526d4b90cde5..000000000000
--- a/app-emulation/libpod/libpod-1.2.0.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_COMMIT="3bd528e583182b4249f3e6bbd8497a8831d89950"
-EGO_PN="github.com/containers/${PN}"
-
-inherit golang-vcs-snapshot systemd
-
-DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
-HOMEPAGE="https://github.com/containers/libpod/"
-SRC_URI="https://github.com/containers/libpod/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64"
-IUSE="apparmor btrfs ostree +rootless selinux"
-REQUIRED_USE="!selinux? ( !ostree )"
-RESTRICT="test"
-
-COMMON_DEPEND="
- app-crypt/gpgme:=
- >=app-emulation/cri-o-1.13.0
- >=app-emulation/runc-1.0.0_rc6
- dev-libs/libassuan:=
- dev-libs/libgpg-error:=
- sys-fs/lvm2
- sys-libs/libseccomp:=
-
- apparmor? ( sys-libs/libapparmor )
- btrfs? ( sys-fs/btrfs-progs )
- ostree? (
- dev-libs/glib:=
- dev-util/ostree:=
- )
- rootless? ( app-emulation/slirp4netns )
- selinux? ( sys-libs/libselinux:= )
-"
-DEPEND="
- ${COMMON_DEPEND}
- dev-go/go-md2man"
-RDEPEND="${COMMON_DEPEND}"
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-src_prepare() {
- default
-
- # Disable installation of python modules here, since those are
- # installed by separate ebuilds.
- sed -e '/^GIT_.*/d' \
- -e 's/$(GO) build/$(GO) build -v -work -x/' \
- -e 's/^\(install:.*\) install\.python$/\1/' \
- -i Makefile || die
-}
-
-src_compile() {
- [[ -f hack/apparmor_tag.sh ]] || die
- if use apparmor; then
- echo -e "#!/bin/sh\necho apparmor" > hack/apparmor_tag.sh || die
- else
- echo -e "#!/bin/sh\ntrue" > hack/apparmor_tag.sh || die
- fi
-
- [[ -f hack/btrfs_installed_tag.sh ]] || die
- if use btrfs; then
- echo -e "#!/bin/sh\ntrue" > hack/btrfs_installed_tag.sh || die
- else
- echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
- hack/btrfs_installed_tag.sh || die
- fi
-
- [[ -f hack/ostree_tag.sh ]] || die
- if use ostree; then
- echo -e "#!/bin/sh\necho ostree" > hack/ostree_tag.sh || die
- else
- echo -e "#!/bin/sh\necho containers_image_ostree_stub" > hack/ostree_tag.sh || die
- fi
-
- [[ -f hack/selinux_tag.sh ]] || die
- if use selinux; then
- echo -e "#!/bin/sh\necho selinux" > hack/selinux_tag.sh || die
- else
- echo -e "#!/bin/sh\ntrue" > hack/selinux_tag.sh || die
- fi
-
- env -u GOCACHE -u LDFLAGS -u XDG_CACHE_HOME GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
- emake all \
- GIT_BRANCH=master \
- GIT_BRANCH_CLEAN=master \
- COMMIT_NO="${EGIT_COMMIT}" \
- GIT_COMMIT="${EGIT_COMMIT}"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install
-
- insinto /etc/containers
- newins test/registries.conf registries.conf.example
- newins test/policy.json policy.json.example
-
- newinitd "${FILESDIR}"/podman.initd podman
-
- systemd_dounit "${S}"/contrib/varlink/*.service "${S}"/contrib/varlink/*.socket
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/podman.logrotated" podman
-
- keepdir /var/lib/containers
-}
-
-pkg_preinst() {
- LIBPOD_ROOTLESS_UPGRADE=false
- if use rootless; then
- has_version 'app-emulation/libpod[rootless]' || LIBPOD_ROOTLESS_UPGRADE=true
- fi
-}
-
-pkg_postinst() {
- local want_newline=false
- if [[ ! ( -e ${EROOT%/*}/etc/containers/policy.json && -e ${EROOT%/*}/etc/containers/registries.conf ) ]]; then
- elog "You need to create the following config files:"
- elog "/etc/containers/registries.conf"
- elog "/etc/containers/policy.json"
- elog "To copy over default examples, use:"
- elog "cp /etc/containers/registries.conf{.example,}"
- elog "cp /etc/containers/policy.json{.example,}"
- want_newline=true
- fi
- if [[ ${LIBPOD_ROOTLESS_UPGRADE} == true ]] ; then
- ${want_newline} && elog ""
- elog "For rootless operation, you need to configure subuid/subgid"
- elog "for user running podman. In case subuid/subgid has only been"
- elog "configured for root, run:"
- elog "usermod --add-subuids 1065536-1131071 <user>"
- elog "usermod --add-subgids 1065536-1131071 <user>"
- want_newline=true
- fi
-}