summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-05-14 18:56:05 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-05-15 08:20:29 +0300
commita7d7c673797b5ff17c5a28b9d1a131d000cac3d7 (patch)
treec6bd90952a9df878808f53fd348400522eca7184 /app-emulation/lxd
parentsys-fs/lxcfs: bump to 4.0.3 (diff)
downloadgentoo-a7d7c673797b5ff17c5a28b9d1a131d000cac3d7.tar.gz
gentoo-a7d7c673797b5ff17c5a28b9d1a131d000cac3d7.tar.bz2
gentoo-a7d7c673797b5ff17c5a28b9d1a131d000cac3d7.zip
app-emulation/lxd: bump to 4.0.1, LTS channel
- always install daemon and tools, - port to GLEP-81 acct. Closes: https://bugs.gentoo.org/701248 Closes: https://bugs.gentoo.org/716632 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation/lxd')
-rw-r--r--app-emulation/lxd/Manifest1
-rw-r--r--app-emulation/lxd/files/lxd-4.0.0.confd23
-rw-r--r--app-emulation/lxd/files/lxd-4.0.0.initd54
-rw-r--r--app-emulation/lxd/lxd-4.0.1.ebuild202
4 files changed, 280 insertions, 0 deletions
diff --git a/app-emulation/lxd/Manifest b/app-emulation/lxd/Manifest
index f0a03569d10b..5c5d670606ba 100644
--- a/app-emulation/lxd/Manifest
+++ b/app-emulation/lxd/Manifest
@@ -1,2 +1,3 @@
DIST lxd-3.14.tar.gz 26141949 BLAKE2B 69004501012c9a873eef77a60df7e5dba25c692224d27b02cd2d2b27533012e71bd7562cb64a17920234746e8be2819bb773365c01422c0b776dd2b7c36b69fe SHA512 3d2d4e61298fc9fde49defad776a398fcccf7639485e810173c9c7f7d939c354a9ad8112a4a631b0850f6eb54435012d289236ff61839416caf95434eb23c8ff
DIST lxd-3.16.tar.gz 24863601 BLAKE2B 0087c00d86ea3f623ea31bc008176e4232bb432f5c431c288f5c5ff3e1658abe4e310509088ddc6b23d8db68f8e93997522b8a5c0b19fd243abee13e11d3deb9 SHA512 11c6c5c49ceb23c31979829937e1baad340b8920481ef5b89b2b6d0b6b05967ec1f446f8b0330c11008f6fecea077eed0858af7fe802c50b52148757584fdfb9
+DIST lxd-4.0.1.tar.gz 25027762 BLAKE2B 1154a427558ad5eda62b63501a2f62a5c3a1b740fac061432b06a1034b75cb906f38d6c43e8215cab8ae0bed328d75a7612c1bb7af3272cdbe3f93235d5bb920 SHA512 1f47f8239cc1d3425fc4cd075487678e219e94deddec10f52a1cd18fbdc0515f54b67552e7b41d0052803c317a861b34cfc83a25776eae7b9673b5c5fd50d70f
diff --git a/app-emulation/lxd/files/lxd-4.0.0.confd b/app-emulation/lxd/files/lxd-4.0.0.confd
new file mode 100644
index 000000000000..68cf344995be
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-4.0.0.confd
@@ -0,0 +1,23 @@
+# Group which owns the shared socket
+LXD_OPTIONS+=" --group lxd"
+
+# Enable cpu profiling into the specified file
+#LXD_OPTIONS+=" --cpuprofile /tmp/lxc_cpu_profile"
+
+# Enable memory profiling into the specified file
+#LXD_OPTIONS+=" --memprofile /tmp/lxc_mem_profile"
+
+# Enable debug mode
+#LXD_OPTIONS+=" --debug"
+
+# For debugging, print a complete stack trace every n seconds
+#LXD_OPTIONS+=" --print-goroutines-every 5"
+
+# Enable verbose mode
+#LXD_OPTIONS+=" -v"
+
+# Logfile to log to
+#LXD_OPTIONS+=" --logfile /var/log/lxd/lxd.log"
+
+# Enable syslog logging
+#LXD_OPTIONS+=" --syslog"
diff --git a/app-emulation/lxd/files/lxd-4.0.0.initd b/app-emulation/lxd/files/lxd-4.0.0.initd
new file mode 100644
index 000000000000..03ec12e44f56
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-4.0.0.initd
@@ -0,0 +1,54 @@
+#!/sbin/openrc-run
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DAEMON=/usr/sbin/lxd
+PIDFILE=/run/lxd.pid
+TIMEOUT=10
+
+extra_commands="stopall"
+
+depend() {
+ need net
+ need lxcfs
+}
+
+start() {
+ ebegin "Starting lxd service"
+
+ modprobe -f loop > /dev/null 2>&1
+
+ # fix permissions on /var/lib/lxd and make sure it exists
+ install -d /var/lib/lxd --group lxd --owner root --mode 0775
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ ${LXD_OPTIONS}
+ eend ${?}
+}
+
+stop() {
+ if [[ ${RC_GOINGDOWN} = YES ]] || [[ ${RC_REBOOT} = YES ]]; then
+ stopall
+ else
+ ebegin "Stopping lxd service (but not containers)."
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend ${?}
+ fi
+}
+
+stopall() {
+ ebegin "Stopping lxd service and containers."
+ lxc stop --all --timeout $TIMEOUT >/dev/null 2>&1
+ if [[ ${?} -ne 0 ]]; then
+ lxc stop --all --force || eerror "Could not stop all containers."
+ fi
+ if "${DAEMON}" shutdown; then
+ rm -f ${PIDFILE}
+ eend 0
+ fi
+ eend ${?}
+}
diff --git a/app-emulation/lxd/lxd-4.0.1.ebuild b/app-emulation/lxd/lxd-4.0.1.ebuild
new file mode 100644
index 000000000000..876dcde968a3
--- /dev/null
+++ b/app-emulation/lxd/lxd-4.0.1.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 eutils linux-info systemd
+
+DESCRIPTION="Fast, dense and secure container management"
+HOMEPAGE="https://linuxcontainers.org/lxd/introduction/ https://github.com/lxc/lxd"
+SRC_URI="https://linuxcontainers.org/downloads/${PN}/${P}.tar.gz"
+
+# Needs to include licenses for all bundled programs.
+LICENSE="Apache-2.0 BSD BSD-2 LGPL-3 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ipv6 nls"
+
+DEPEND="app-arch/xz-utils
+ >=app-emulation/lxc-3.0.0[seccomp]
+ dev-lang/tcl
+ dev-libs/libuv
+ dev-libs/lzo
+ net-dns/dnsmasq[dhcp,ipv6?]"
+RDEPEND="${DEPEND}
+ acct-group/lxd
+ net-firewall/ebtables
+ net-firewall/iptables[ipv6?]
+ sys-apps/iproute2[ipv6?]
+ sys-fs/fuse:0=
+ sys-fs/lxcfs
+ sys-fs/squashfs-tools
+ virtual/acl"
+BDEPEND="dev-lang/go
+ nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="
+ ~BRIDGE
+ ~DUMMY
+ ~IP6_NF_NAT
+ ~IP6_NF_TARGET_MASQUERADE
+ ~IPV6
+ ~IP_NF_NAT
+ ~IP_NF_TARGET_MASQUERADE
+ ~MACVLAN
+ ~NETFILTER_XT_MATCH_COMMENT
+ ~NET_IPGRE
+ ~NET_IPGRE_DEMUX
+ ~NET_IPIP
+ ~NF_NAT_MASQUERADE_IPV4
+ ~NF_NAT_MASQUERADE_IPV6
+ ~VXLAN
+"
+
+# To no one's surprise uses internet connection.
+RESTRICT="test"
+
+# Go magic.
+QA_PREBUILT="/usr/lib/lxd/libdqlite.so.0.0.1
+ /usr/bin/fuidshift
+ /usr/bin/lxc
+ /usr/bin/lxc-to-lxd
+ /usr/bin/lxd-agent
+ /usr/bin/lxd-benchmark
+ /usr/bin/lxd-p2c
+ /usr/sbin/lxd"
+
+EGO_PN="github.com/lxc/lxd"
+GOPATH="${S}/_dist" # this seems to reset every now and then, though
+
+common_op() {
+ local i
+ for i in dqlite raft; do
+ cd "${GOPATH}"/deps/${i} || die "failed to switch dir to ${i}"
+ "${@}"
+ cd "${S}" || die "failed to switch dir back from ${i} to ${S}"
+ done
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:\./configure:./configure --prefix=/usr --libdir=${EPREFIX}/usr/lib/lxd:g" \
+ -e "s:make:make ${MAKEOPTS}:g" \
+ Makefile || die
+
+ cd "${GOPATH}"/deps/libco || die
+ sed -i 's#lib$#lib/lxd#' Makefile || die
+
+ common_op eautoreconf
+}
+
+src_configure() {
+ export GOPATH="${S}/_dist"
+
+ export CO_CFLAGS="-I${GOPATH}/deps/libco/"
+ export CO_LIBS="${GOPATH}/deps/libco/"
+
+ export RAFT_CFLAGS="-I${GOPATH}/deps/raft/include/"
+ export RAFT_LIBS="${GOPATH}/deps/raft/.libs"
+
+ export SQLITE_CFLAGS="-I${GOPATH}/deps/sqlite"
+ export SQLITE_LIBS="${GOPATH}/deps/sqlite/.libs"
+
+ export PKG_CONFIG_PATH="${GOPATH}/sqlite/:${GOPATH}/libco/:${GOPATH}/raft/"
+
+ cd "${GOPATH}/deps/sqlite" || die
+ econf --enable-replication --disable-amalgamation --disable-tcl --libdir="${EPREFIX}/usr/lib/lxd"
+
+ common_op econf --libdir="${EPREFIX}"/usr/lib/lxd
+}
+
+src_compile() {
+ export GOPATH="${S}/_dist"
+
+ export CGO_CFLAGS="${CGO_CFLAGS} -I${GOPATH}/deps/sqlite/ -I${GOPATH}/deps/dqlite/include/ -I${GOPATH}/deps/raft/include/ -I${GOPATH}/deps/libco/"
+ export CGO_LDFLAGS="${CGO_LDFLAGS} -L${GOPATH}/deps/sqlite/.libs/ -L${GOPATH}/deps/dqlite/.libs/ -L${GOPATH}/deps/raft/.libs -L${GOPATH}/deps/libco/ -Wl,-rpath,${EPREFIX}/usr/lib/lxd"
+ export LD_LIBRARY_PATH="${GOPATH}/deps/sqlite/.libs/:${GOPATH}/deps/dqlite/.libs/:${GOPATH}/deps/raft/.libs:${GOPATH}/deps/libco/:${LD_LIBRARY_PATH}"
+
+ local j
+ for j in sqlite raft libco; do
+ cd "${GOPATH}"/deps/${j} || die
+ emake
+ done
+
+ ln -s libco.so.0.1.0 libco.so || die
+
+ cd "${GOPATH}/deps/dqlite" || die
+ emake CFLAGS="-I${GOPATH}/deps/sqlite -I${GOPATH}/deps/raft/include" LDFLAGS="-L${GOPATH}/deps/sqlite -L${GOPATH}/deps/raft"
+
+ cd "${S}" || die
+
+ for k in fuidshift lxd-agent lxd-benchmark lxd-p2c lxc lxc-to-lxd; do
+ go install -v -x ${EGO_PN}/${k} || die "failed compiling ${k}"
+ done
+
+ go install -v -x -tags libsqlite3 ${EGO_PN}/lxd || die "Failed to build the daemon"
+
+ use nls && emake build-mo
+}
+
+src_test() {
+ export GOPATH="${S}/_dist"
+
+ # This is mostly a copy/paste from the Makefile's "check" rule, but
+ # patching the Makefile to work in a non "fully-qualified" go namespace
+ # was more complicated than this modest copy/paste.
+ # Also: sorry, for now a network connection is needed to run tests.
+ # Will properly bundle test dependencies later.
+ go get -v -x github.com/rogpeppe/godeps || die
+ go get -v -x github.com/remyoudompheng/go-misc/deadcode || die
+ go get -v -x github.com/golang/lint/golint || die
+ go test -v ${EGO_PN}/lxd || die
+}
+
+src_install() {
+ local bindir="_dist/bin"
+ export GOPATH="${S}/_dist"
+
+ dosbin ${bindir}/lxd
+
+ for l in fuidshift lxd-agent lxd-benchmark lxd-p2c lxc lxc-to-lxd; do
+ dobin ${bindir}/${l}
+ done
+
+ for m in dqlite libco raft sqlite; do
+ cd "${GOPATH}"/deps/${m} || die "failed switching into ${GOPATH}/${m}"
+ emake DESTDIR="${D}" install
+ done
+
+ cd "${S}" || die
+
+ # We only need libraries, and we don't want anything to link against these.
+ rm "${ED}"/usr/bin/sqlite3 || die
+ rm -r "${ED}"/usr/include || die
+ rm -r "${ED}"/usr/lib/lxd/*.a || die
+ rm -r "${ED}"/usr/lib/lxd/pkgconfig || die
+
+ newbashcomp scripts/bash/lxd-client lxc
+
+ newconfd "${FILESDIR}"/${PN}-4.0.0.confd lxd
+ newinitd "${FILESDIR}"/${PN}-4.0.0.initd lxd
+
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+
+ dodoc AUTHORS doc/*
+ use nls && domo po/*.mo
+}
+
+pkg_postinst() {
+ elog
+ elog "Consult https://wiki.gentoo.org/wiki/LXD for more information,"
+ elog "including a Quick Start."
+ elog
+ elog "Optional features:"
+ optfeature "apparmor support" app-emulation/lxc[apparmor]
+ optfeature "btrfs storage backend" sys-fs/btrfs-progs
+ optfeature "lvm2 storage backend" sys-fs/lvm2
+ optfeature "zfs storage backend" sys-fs/zfs
+ elog
+ elog "Be sure to add your local user to the lxd group."
+}