summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0x501D <mail@void.so>2021-09-30 11:21:04 +0300
committerPatrice Clement <monsieurp@gentoo.org>2021-10-13 09:14:35 +0200
commitf58fb0cdd0d95465d09a146c41a2a9b0c81074a8 (patch)
tree52a3a536ab332e20c54134e6519f3b0525e8fbb6 /app-emulation/nemu
parentsci-libs/szip: drop 2.1.1 (diff)
downloadgentoo-f58fb0cdd0d95465d09a146c41a2a9b0c81074a8.tar.gz
gentoo-f58fb0cdd0d95465d09a146c41a2a9b0c81074a8.tar.bz2
gentoo-f58fb0cdd0d95465d09a146c41a2a9b0c81074a8.zip
app-emulation/nemu: version bump to 3.0.0.
Closes: https://github.com/gentoo/gentoo/pull/22446 Closes: https://bugs.gentoo.org/817821 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Pavel Balaev <mail@void.so> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-emulation/nemu')
-rw-r--r--app-emulation/nemu/Manifest2
-rw-r--r--app-emulation/nemu/metadata.xml10
-rw-r--r--app-emulation/nemu/nemu-3.0.0.ebuild (renamed from app-emulation/nemu/nemu-2.5.0-r1.ebuild)15
3 files changed, 19 insertions, 8 deletions
diff --git a/app-emulation/nemu/Manifest b/app-emulation/nemu/Manifest
index 52a97fcdc535..c625274b1045 100644
--- a/app-emulation/nemu/Manifest
+++ b/app-emulation/nemu/Manifest
@@ -1 +1 @@
-DIST nemu-2.5.0.tar.gz 108742 BLAKE2B e68cbf50d56983873656d8e3428cb3ffaa09cafc9cbc8e545d72bf9dfb61e64a06bdc41c3f50011c4c488017efe33afe9fa1d634aae6e9151c45a7d3971c60db SHA512 081199413c41e545d23704091760c4a10b8dcdb21d9d0e6add1e549fa33bdd988490034767e08dee681eee6d06899104b8282cafc4578e06a0eabc505325bbdc
+DIST nemu-3.0.0.tar.gz 151223 BLAKE2B a71875eb727eed13bc252cee072e1c5b25bf7ea106f51ddddfb8e8bfacf21e030b1c4045de2353d40121b78756b131de1a376891197f6d553430b4b30f53bf3e SHA512 59dae5364659dda5d7c05ba6378b6e20c5d2c5b619cb919c49036918a887574b75f5d568cbfa8f21ecf790778c9de55266f5c5e3e90cc991f613a6408b10a1df
diff --git a/app-emulation/nemu/metadata.xml b/app-emulation/nemu/metadata.xml
index 8976af299f5d..0d69beebd2d0 100644
--- a/app-emulation/nemu/metadata.xml
+++ b/app-emulation/nemu/metadata.xml
@@ -5,11 +5,19 @@
<email>monsieurp@gentoo.org</email>
<name>Patrice Clement</name>
</maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>mail@void.so</email>
+ <name>Pavel Balaev</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<use>
<flag name="vnc-client">Adds support for external VNC client</flag>
- <flag name="savevm">Adds support for QEMU savevm snapshots (experimental, QEMU must be patched)</flag>
<flag name="spice">Adds Spice protocol support</flag>
<flag name="ovf">Adds support for OVA/OVF import</flag>
<flag name="network-map">Adds possibility of exporting network map to SVG</flag>
+ <flag name="remote-api">Adds API for remote control</flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/nemu/nemu-2.5.0-r1.ebuild b/app-emulation/nemu/nemu-3.0.0.ebuild
index 30d137f15fd9..5abe885a8f49 100644
--- a/app-emulation/nemu/nemu-2.5.0-r1.ebuild
+++ b/app-emulation/nemu/nemu-3.0.0.ebuild
@@ -14,10 +14,10 @@ SRC_URI="https://github.com/nemuTUI/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.g
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="dbus network-map +ovf +savevm spice +vnc-client"
+IUSE="dbus network-map +ovf spice +vnc-client remote-api"
RDEPEND="
- app-emulation/qemu[vnc,virtfs,spice?]
+ >=app-emulation/qemu-6.0.0-r3[vnc,virtfs,spice?]
dev-db/sqlite:3=
sys-libs/ncurses:=[unicode(+)]
virtual/libusb:1
@@ -28,6 +28,7 @@ RDEPEND="
dev-libs/libxml2:2
app-arch/libarchive:=
)
+ remote-api? ( dev-libs/openssl )
spice? ( app-emulation/virt-viewer )
vnc-client? ( net-misc/tigervnc )
"
@@ -51,14 +52,11 @@ pkg_pretend() {
}
src_configure() {
- # -DNM_USE_UTF: Enable unicode unconditionally. We already
- # depended on ncurses[unicode].
# -DNM_WITH_QEMU: Do not embbed qemu.
local mycmakeargs=(
- -DNM_SAVEVM_SNAPSHOTS=$(usex savevm)
- -DNM_USE_UTF=on
-DNM_WITH_DBUS=$(usex dbus)
-DNM_WITH_NETWORK_MAP=$(usex network-map)
+ -DNM_WITH_REMOTE=$(usex remote-api)
-DNM_WITH_OVF_SUPPORT=$(usex ovf)
-DNM_WITH_QEMU=off
-DNM_WITH_SPICE=$(usex spice)
@@ -67,6 +65,11 @@ src_configure() {
cmake_src_configure
}
+src_install() {
+ cmake_src_install
+ docompress -x /usr/share/man/man1/nemu.1.gz
+}
+
pkg_postinst() {
elog "For non-root usage execute script:"
elog "/usr/share/nemu/scripts/setup_nemu_nonroot.sh linux <username>"