summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 20:29:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:02 +0100
commitd6c2043d18fc0ed39371d7c0cd3b90aa7394a2a4 (patch)
tree5ec659037d40623dff973ca798c2f3a65b466004 /app-emulation/pcem/pcem-17-r1.ebuild
parentapp-crypt/ssss: drop 0.5.7 (diff)
downloadgentoo-d6c2043d18fc0ed39371d7c0cd3b90aa7394a2a4.tar.gz
gentoo-d6c2043d18fc0ed39371d7c0cd3b90aa7394a2a4.tar.bz2
gentoo-d6c2043d18fc0ed39371d7c0cd3b90aa7394a2a4.zip
app-emulation/pcem: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-emulation/pcem/pcem-17-r1.ebuild')
-rw-r--r--app-emulation/pcem/pcem-17-r1.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/app-emulation/pcem/pcem-17-r1.ebuild b/app-emulation/pcem/pcem-17-r1.ebuild
new file mode 100644
index 000000000000..bad0762a6e55
--- /dev/null
+++ b/app-emulation/pcem/pcem-17-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit autotools desktop flag-o-matic wxwidgets
+
+DESCRIPTION="A PC emulator that specializes in running old operating systems and software"
+HOMEPAGE="
+ https://pcem-emulator.co.uk/
+ https://github.com/sarah-walker-pcem/pcem/
+"
+SRC_URI="https://pcem-emulator.co.uk/files/PCemV${PV}Linux.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="alsa networking"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libsdl2
+ media-libs/openal
+ x11-libs/wxGTK:${WX_GTK_VER}[tiff,X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "TESTED.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-17-respect-cflags.patch" )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets
+
+ # Does not compile with -fno-common.
+ # See https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=3&t=3443
+ append-cflags -fcommon
+
+ local myeconfargs=(
+ --enable-release-build
+ $(use_enable alsa)
+ $(use_enable networking)
+ --with-wx-config="${WX_CONFIG}"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/pcem
+ doins -r configs nvr roms
+
+ newicon src/icons/32x32/motherboard.png pcem.png
+ make_desktop_entry "pcem" "PCem" pcem "Development;Utility"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "In order to use PCem, you will need some roms for various emulated systems."
+ elog "You can either install globally for all users or locally for yourself."
+ elog ""
+ elog "To install globally, put your ROM files into '${ROOT}/usr/share/pcem/roms/<system>'."
+ elog "To install locally, put your ROM files into '~/.pcem/roms/<system>'."
+}