summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-26 15:51:53 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-26 16:31:28 -0400
commit48462978f96b6a32a1faee1bc5f6a4beaeb46d56 (patch)
tree2c43f7da4087bd6018642da58adeb38101b08c4f /app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild
parentapp-vim/omnicppcomplete: bump EAPI (diff)
downloadgentoo-48462978f96b6a32a1faee1bc5f6a4beaeb46d56.tar.gz
gentoo-48462978f96b6a32a1faee1bc5f6a4beaeb46d56.tar.bz2
gentoo-48462978f96b6a32a1faee1bc5f6a4beaeb46d56.zip
app-emulation/phpvirtualbox: drop EAPI=2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild')
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild
deleted file mode 100644
index de7e19448c92..000000000000
--- a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit versionator eutils webapp
-
-MY_PV="$(replace_version_separator 2 '-')"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Web-based administration for VirtualBox in PHP"
-HOMEPAGE="https://sourceforge.net/projects/phpvirtualbox/"
-SRC_URI="https://${PN}.googlecode.com/files/${MY_P}.zip"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-lang/php[session,unicode,soap,gd]
- virtual/httpd-php
-"
-DEPEND="app-arch/unzip"
-
-src_install() {
- webapp_src_preinst
-
- cd ${MY_P}
-
- dodoc CHANGELOG.txt LICENSE.txt README.txt || die
- rm -f CHANGELOG.txt LICENSE.txt README.txt
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
- webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
-
- webapp_src_install
- if has_version app-emulation/virtualbox[vboxwebsrv] || \
- has_version app-emulation/virtualbox-bin[vboxwebsrv]
- then
- newinitd "${FILESDIR}"/vboxinit-initd vboxinit
- fi
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
- elog "Local or remote virtualbox hosts must be compiled with"
- elog "'vboxwebsrv' useflag and the respective init script"
- elog "must be running to use this interface"
- elog " /etc/init.d/vboxwebsrv start"
- elog
- elog "To enable the automatic startup mode feature uncomment the"
- elog "following line in the config.php file:"
- elog " var \$startStopConfig = true;"
- elog
- elog "You should also add the /etc/init.d/vboxinit script to the"
- elog "default runlevel on the virtualbox host:"
- elog "\`rc-update add vboxinit default\`"
- elog "If the server is on a remote host, than the script must be"
- elog "copied manually from"
- elog "${FILESDIR}/vboxinit-initd to /etc/init.d/vboxinit"
- elog "on the remote host."
-}