summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-03-08 11:58:03 +0000
committerMarek Szuba <marecki@gentoo.org>2023-03-08 13:22:33 +0000
commitf74176e03cadc2d80ce6d0c627c0b15fc83138f9 (patch)
tree1727c926230829b591ee33e89f0e0e19fd924e95 /app-emulation/protontricks
parentdev-vcs/pre-commit: add 3.1.1 (diff)
downloadgentoo-f74176e03cadc2d80ce6d0c627c0b15fc83138f9.tar.gz
gentoo-f74176e03cadc2d80ce6d0c627c0b15fc83138f9.tar.bz2
gentoo-f74176e03cadc2d80ce6d0c627c0b15fc83138f9.zip
app-emulation/protontricks: add 1.10.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/protontricks-1.10.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index b9ded840fc67..a2ade930a592 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1 +1,2 @@
DIST protontricks-1.10.1.tar.gz 160943 BLAKE2B 12361ce009a62bdba8c420069f87879bf22e047df8bd6d843fb8672222fe6ab04d61f03a44c43a147729461a2f872e2239ee97d737aba28ffdbb273e797be218 SHA512 0b6e3277ea8a106d2bc52cc805b0c3a023733f0a6554fabfe9f32ff27d1bdf04058a419a719c7ca81dc45759a803a83b03408806e4b9328664e572655a3c4df0
+DIST protontricks-1.10.2.tar.gz 162325 BLAKE2B 5e9d0bf2970ad0e9a5ef5e399af5e327781c94f3e76e36db3a93a93d59102436a54e926a72a22b4640178534d2b9e62452543706c7ec10ce4591f15ce00ac4f3 SHA512 f644e13f356f899b8084ed1d347c210b624c09676f3a644f973610d1134658dd2951e8f85178606639b0eca8c386e9abac89c658a7076e4126278ff955549f10
diff --git a/app-emulation/protontricks/protontricks-1.10.2.ebuild b/app-emulation/protontricks/protontricks-1.10.2.ebuild
new file mode 100644
index 000000000000..dae98e9c173d
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.10.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}