summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-04-08 13:43:48 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-04-08 13:51:13 -0500
commit0d77f947c3b17674479e6727c863708c369a75fd (patch)
tree9feb7edca79ccf0d7f6e806660ab72319e68ddd8 /app-emulation/qemu
parentdev-python/pyrsistent: 0.16.0 (diff)
downloadgentoo-0d77f947c3b17674479e6727c863708c369a75fd.tar.gz
gentoo-0d77f947c3b17674479e6727c863708c369a75fd.tar.bz2
gentoo-0d77f947c3b17674479e6727c863708c369a75fd.zip
app-emulation/qemu: reverse order of audio backends
Closes: https://bugs.gentoo.org/716202 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-4.2.0-r2.ebuild4
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-emulation/qemu/qemu-4.2.0-r2.ebuild b/app-emulation/qemu/qemu-4.2.0-r2.ebuild
index e67734093dfb..c23828e7a8d6 100644
--- a/app-emulation/qemu/qemu-4.2.0-r2.ebuild
+++ b/app-emulation/qemu/qemu-4.2.0-r2.ebuild
@@ -496,10 +496,10 @@ qemu_src_configure() {
if [[ ! ${buildtype} == "user" ]] ; then
# audio options
local audio_opts=(
+ $(usex pulseaudio pa "")
+ $(usev sdl)
$(usev alsa)
$(usev oss)
- $(usev sdl)
- $(usex pulseaudio pa "")
)
conf_opts+=(
--audio-drv-list=$(printf "%s," "${audio_opts[@]}")
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index a5144a568f4b..9020f7fa5989 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -491,10 +491,10 @@ qemu_src_configure() {
if [[ ! ${buildtype} == "user" ]] ; then
# audio options
local audio_opts=(
+ $(usex pulseaudio pa "")
+ $(usev sdl)
$(usev alsa)
$(usev oss)
- $(usev sdl)
- $(usex pulseaudio pa "")
)
conf_opts+=(
--audio-drv-list=$(printf "%s," "${audio_opts[@]}")