summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-03-12 01:37:47 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-03-12 01:38:16 +0100
commit25016a2d27ade1c95fac6018c6fbe33ca5909347 (patch)
tree3b32f40154c62fabce3e202f04ffef790b694390 /app-emulation/qemu
parentnet-misc/gallery-dl: bump to 1.25.0 (diff)
downloadgentoo-25016a2d27ade1c95fac6018c6fbe33ca5909347.tar.gz
gentoo-25016a2d27ade1c95fac6018c6fbe33ca5909347.tar.bz2
gentoo-25016a2d27ade1c95fac6018c6fbe33ca5909347.zip
app-emulation/qemu: rebase 2 patches for git master
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/files/qemu-8.0.0-disable-keymap.patch27
-rw-r--r--app-emulation/qemu/files/qemu-8.0.0-make.patch12
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild4
3 files changed, 41 insertions, 2 deletions
diff --git a/app-emulation/qemu/files/qemu-8.0.0-disable-keymap.patch b/app-emulation/qemu/files/qemu-8.0.0-disable-keymap.patch
new file mode 100644
index 000000000000..aab5dde5fbd9
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-8.0.0-disable-keymap.patch
@@ -0,0 +1,27 @@
+diff -ruN qemu-9999.orig/meson.build qemu-9999/meson.build
+--- qemu-9999.orig/meson.build 2023-03-12 01:17:38.273756012 +0100
++++ qemu-9999/meson.build 2023-03-12 01:18:44.854716789 +0100
+@@ -667,6 +667,8 @@
+
+ if get_option('xkbcommon').auto() and not have_system and not have_tools
+ xkbcommon = not_found
++elif get_option('xkbcommon').disabled()
++ xkbcommon = not_found
+ else
+ xkbcommon = dependency('xkbcommon', required: get_option('xkbcommon'),
+ method: 'pkg-config', kwargs: static_kwargs)
+diff -ruN qemu-9999.orig/pc-bios/keymaps/meson.build qemu-9999/pc-bios/keymaps/meson.build
+--- qemu-9999.orig/pc-bios/keymaps/meson.build 2023-03-12 01:17:38.321756706 +0100
++++ qemu-9999/pc-bios/keymaps/meson.build 2023-03-12 01:20:22.015111600 +0100
+@@ -33,8 +33,10 @@
+ 'tr': '-l tr',
+ }
+
+-if meson.is_cross_build() or not xkbcommon.found()
++if meson.is_cross_build()
+ native_qemu_keymap = find_program('qemu-keymap', required: false, disabler: true)
++elif get_option('xkbcommon').disabled()
++ native_qemu_keymap = not_found
+ else
+ native_qemu_keymap = qemu_keymap
+ endif
diff --git a/app-emulation/qemu/files/qemu-8.0.0-make.patch b/app-emulation/qemu/files/qemu-8.0.0-make.patch
new file mode 100644
index 000000000000..4bf3f7157713
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-8.0.0-make.patch
@@ -0,0 +1,12 @@
+diff -ruN qemu-9999.orig/configure qemu-9999/configure
+--- qemu-9999.orig/configure 2023-03-12 01:26:15.488133462 +0100
++++ qemu-9999/configure 2023-03-12 01:29:19.355724020 +0100
+@@ -1068,7 +1068,7 @@
+ fi
+ fi
+
+-if ! has "$make"
++if ! has $make
+ then
+ error_exit "GNU make ($make) not found"
+ fi
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 61f5fdffb2eb..874bcfff7852 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -308,8 +308,8 @@ RDEPEND="${CDEPEND}
)"
PATCHES=(
- "${FILESDIR}"/${PN}-5.2.0-disable-keymap.patch
- "${FILESDIR}"/${PN}-6.0.0-make.patch
+ "${FILESDIR}"/${PN}-8.0.0-disable-keymap.patch
+ "${FILESDIR}"/${PN}-8.0.0-make.patch
"${FILESDIR}"/${PN}-7.1.0-also-build-virtfs-proxy-helper.patch
"${FILESDIR}"/${PN}-7.1.0-capstone-include-path.patch
)