summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-20 14:16:37 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-20 14:16:42 -0500
commit64ce86d1757fa73a25cdca0287d5360cca5b531b (patch)
treeb1ce5766d375e5fbe741529c32ac6645483c17b2 /app-emulation/qemu
parentprofiles/package.mask: Mask unusable gkeys-gen release #567768 (diff)
downloadgentoo-64ce86d1757fa73a25cdca0287d5360cca5b531b.tar.gz
gentoo-64ce86d1757fa73a25cdca0287d5360cca5b531b.tar.bz2
gentoo-64ce86d1757fa73a25cdca0287d5360cca5b531b.zip
app-emulation/qemu: disable libgcrypt usage #568856
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-2.5.0.ebuild6
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/app-emulation/qemu/qemu-2.5.0.ebuild b/app-emulation/qemu/qemu-2.5.0.ebuild
index 249a20a6dda7..70f595ea5b5c 100644
--- a/app-emulation/qemu/qemu-2.5.0.ebuild
+++ b/app-emulation/qemu/qemu-2.5.0.ebuild
@@ -343,6 +343,11 @@ qemu_src_configure() {
--disable-guest-agent
--disable-strip
--disable-werror
+ # We support gnutls/nettle for crypto operations. It is possible
+ # to use gcrypt when gnutls/nettle are disabled (but not when they
+ # are enabled), but it's not really worth the hassle. Disable it
+ # all the time to avoid automatically detecting it. #568856
+ --disable-gcrypt
--python="${PYTHON}"
--cc="$(tc-getCC)"
--cxx="$(tc-getCXX)"
@@ -372,6 +377,7 @@ qemu_src_configure() {
$(conf_softmmu fdt)
$(conf_softmmu glusterfs)
$(conf_softmmu gnutls)
+ $(conf_softmmu gnutls nettle)
$(conf_softmmu gtk)
$(conf_softmmu infiniband rdma)
$(conf_softmmu iscsi libiscsi)
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 249a20a6dda7..70f595ea5b5c 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -343,6 +343,11 @@ qemu_src_configure() {
--disable-guest-agent
--disable-strip
--disable-werror
+ # We support gnutls/nettle for crypto operations. It is possible
+ # to use gcrypt when gnutls/nettle are disabled (but not when they
+ # are enabled), but it's not really worth the hassle. Disable it
+ # all the time to avoid automatically detecting it. #568856
+ --disable-gcrypt
--python="${PYTHON}"
--cc="$(tc-getCC)"
--cxx="$(tc-getCXX)"
@@ -372,6 +377,7 @@ qemu_src_configure() {
$(conf_softmmu fdt)
$(conf_softmmu glusterfs)
$(conf_softmmu gnutls)
+ $(conf_softmmu gnutls nettle)
$(conf_softmmu gtk)
$(conf_softmmu infiniband rdma)
$(conf_softmmu iscsi libiscsi)