summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-11-22 00:24:00 -0600
committerJohn Helmert III <ajak@gentoo.org>2022-11-22 00:24:00 -0600
commit959a0a08727b69e035750e5523cff25ed2f89c6c (patch)
treeb358db874889ad143bedd05e9c5e13f77ceca99f /app-emulation/qemu
parentapp-emulation/qemu: sync live (diff)
downloadgentoo-959a0a08727b69e035750e5523cff25ed2f89c6c.tar.gz
gentoo-959a0a08727b69e035750e5523cff25ed2f89c6c.tar.bz2
gentoo-959a0a08727b69e035750e5523cff25ed2f89c6c.zip
app-emulation/qemu: revbump 7.1.0 to force-on vhost-user-fs
Bug: https://bugs.gentoo.org/873190 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-7.1.0-r2.ebuild (renamed from app-emulation/qemu/qemu-7.1.0-r1.ebuild)31
1 files changed, 3 insertions, 28 deletions
diff --git a/app-emulation/qemu/qemu-7.1.0-r1.ebuild b/app-emulation/qemu/qemu-7.1.0-r2.ebuild
index 8a48da933fe9..a71f1773c462 100644
--- a/app-emulation/qemu/qemu-7.1.0-r1.ebuild
+++ b/app-emulation/qemu/qemu-7.1.0-r2.ebuild
@@ -60,7 +60,7 @@ IUSE="accessibility +aio alsa bpf bzip2 capstone +caps +curl debug ${QEMU_DOC_US
plugins +png pulseaudio python rbd sasl +seccomp sdl sdl-image selinux
+slirp
smartcard snappy spice ssh static static-user systemtap test udev usb
- usbredir vde +vhost-net vhost-user-fs virgl virtfs +vnc vte xattr xen
+ usbredir vde +vhost-net virgl virtfs +vnc vte xattr xen
zstd"
COMMON_TARGETS="
@@ -117,7 +117,8 @@ IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
RESTRICT="!test? ( test )"
# Allow no targets to be built so that people can get a tools-only build.
# Block USE flag configurations known to not work.
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
+REQUIRED_USE="caps seccomp
+ ${PYTHON_REQUIRED_USE}
qemu_softmmu_targets_arm? ( fdt )
qemu_softmmu_targets_microblaze? ( fdt )
qemu_softmmu_targets_mips64el? ( fdt )
@@ -129,7 +130,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
sdl-image? ( sdl )
static? ( static-user !alsa !gtk !jack !opengl !pam !pulseaudio !plugins !rbd !snappy !udev )
static-user? ( !plugins )
- vhost-user-fs? ( caps seccomp )
virgl? ( opengl )
virtfs? ( caps xattr )
vnc? ( gnutls )
@@ -637,16 +637,6 @@ qemu_src_configure() {
--disable-tools
)
local static_flag="static"
-
- for target in ${IUSE_SOFTMMU_TARGETS}; do
- if use "qemu_softmmu_targets_${target}"; then
- conf_opts+=(
- # For some reason, adding this with the setting set
- # to on *or* off makes the build always fail.
- # --with-devices-${target}=gentoo
- )
- fi
- done
;;
tools)
conf_opts+=(
@@ -698,21 +688,6 @@ src_configure() {
if use "qemu_softmmu_targets_${target}"; then
softmmu_targets+=",${target}-softmmu"
softmmu_bins+=( "qemu-system-${target}" )
-
- # Needed to rework vhost-user-fs handling thanks to https://gitlab.com/qemu-project/qemu/-/commit/5166dab
- # The option was converted into being configurable by
- # Kconfig's. So, to enable it, we insert the necessary
- # options into each arch's softmmu target gentoo.mak file,
- # then configure with --with-devices-${target}=gentoo.
- if use vhost-user-fs; then
- echo "CONFIG_VHOST_USER_FS=y for ${target}-softmmu" || die
- echo "CONFIG_VIRTIO=y" >> "configs/devices/${target}-softmmu/gentoo.mak" || die
- echo "CONFIG_VHOST_USER_FS=y" >> "configs/devices/${target}-softmmu/gentoo.mak" || die
- else
- echo "CONFIG_VHOST_USER_FS=n for ${target}-softmmu" || die
- echo "CONFIG_VIRTIO=n" >> "configs/devices/${target}-softmmu/gentoo.mak" || die
- echo "CONFIG_VHOST_USER_FS=n" >> "configs/devices/${target}-softmmu/gentoo.mak" || die
- fi
fi
done