summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-04-07 20:48:29 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-04-07 21:29:41 -0500
commitb86a3a0d6f91117377f3a339e61ff389eb3a25d1 (patch)
treef7cf6faf6f038bf2a5a48b860b70eb527074612b /app-emulation/qemu
parentapp-emulation/libvirt-snmp: drop old version (diff)
downloadgentoo-b86a3a0d6f91117377f3a339e61ff389eb3a25d1.tar.gz
gentoo-b86a3a0d6f91117377f3a339e61ff389eb3a25d1.tar.bz2
gentoo-b86a3a0d6f91117377f3a339e61ff389eb3a25d1.zip
app-emulation/qemu: synchronize live ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 69e36290636d..dbfe40f35758 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -641,9 +641,11 @@ generate_initd() {
sparc*) qcpu="sparc";;
esac
+ # we use 'printf' here to be portable across 'sh'
+ # implementations: #679168
cat <<EOF >>"${out}"
if [ "\${cpu}" != "${qcpu}" -a -x "${interpreter}" ] ; then
- echo ':${package}:M::${magic}:${mask}:${interpreter}:'"\${QEMU_BINFMT_FLAGS}" >/proc/sys/fs/binfmt_misc/register
+ printf '%s\n' ':${package}:M::${magic}:${mask}:${interpreter}:'"\${QEMU_BINFMT_FLAGS}" >/proc/sys/fs/binfmt_misc/register
fi
EOF