summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-11-20 23:40:18 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-11-20 23:40:18 +0100
commit8a585fa23a9221de5e564aba408855d0ab533cda (patch)
tree3f95b5012f55c7cc3f8f747f9291b57072e02cc7 /app-emulation/reg/reg-0.16.1.ebuild
parentsys-cluster/kubeadm: Remove old (diff)
downloadgentoo-8a585fa23a9221de5e564aba408855d0ab533cda.tar.gz
gentoo-8a585fa23a9221de5e564aba408855d0ab533cda.tar.bz2
gentoo-8a585fa23a9221de5e564aba408855d0ab533cda.zip
app-emulation/reg: Version bump to 0.16.1
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/reg/reg-0.16.1.ebuild')
-rw-r--r--app-emulation/reg/reg-0.16.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/reg/reg-0.16.1.ebuild b/app-emulation/reg/reg-0.16.1.ebuild
new file mode 100644
index 000000000000..5d47aa4a646f
--- /dev/null
+++ b/app-emulation/reg/reg-0.16.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_VENDOR=( "gopkg.in/yaml.v2 eb3733d160e7 github.com/go-yaml/yaml" )
+
+inherit golang-build golang-vcs-snapshot user
+
+EGO_PN="github.com/genuinetools/reg"
+GIT_COMMIT="4203e559f331009df04a3ca47820989c6c43e138"
+ARCHIVE_URI="https://${EGO_PN}/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz
+ ${EGO_VENDOR_URI}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Docker registry v2 command line client"
+HOMEPAGE="https://github.com/genuinetools/reg"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup reg
+ enewuser reg -1 -1 /var/lib/reg reg
+}
+
+src_prepare() {
+ pushd src/${EGO_PN} || die
+ eapply "${FILESDIR}"/reg-0.16.0-config.patch
+ default
+ popd || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" GO111MODULE=on go build -mod=vendor -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc src/${EGO_PN}/README.md
+ insinto /var/lib/${PN}
+ doins -r src/${EGO_PN}/server/*
+ newinitd "${FILESDIR}"/reg.initd reg
+ newconfd "${FILESDIR}"/reg.confd reg
+
+ keepdir /var/log/reg
+ fowners -R reg:reg /var/log/reg /var/lib/reg/static
+}