summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2015-12-06 23:14:50 -0600
committerDoug Goldstein <cardoe@gentoo.org>2015-12-06 23:15:22 -0600
commit37c1ec7ef31a51206421f03a2df489ec7d7ca244 (patch)
treec9d7d7b8664ba37245736a346337ab19859586cc /app-emulation/runc
parentprofiles/package.mask: pmask pecl-drizzle, drizzle for removal (diff)
downloadgentoo-37c1ec7ef31a51206421f03a2df489ec7d7ca244.tar.gz
gentoo-37c1ec7ef31a51206421f03a2df489ec7d7ca244.tar.bz2
gentoo-37c1ec7ef31a51206421f03a2df489ec7d7ca244.zip
app-emulation/runc: version bump
bump to latest upstream release. Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'app-emulation/runc')
-rw-r--r--app-emulation/runc/runc-0.0.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-emulation/runc/runc-0.0.5.ebuild b/app-emulation/runc/runc-0.0.5.ebuild
new file mode 100644
index 000000000000..5cd38367f22d
--- /dev/null
+++ b/app-emulation/runc/runc-0.0.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://runc.io"
+
+GITHUB_URI="github.com/opencontainers/runc"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://${GITHUB_URI}.git"
+ inherit git-r3
+else
+ SRC_URI="https://${GITHUB_URI}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+seccomp"
+
+DEPEND=">=dev-lang/go-1.4:="
+RDEPEND="seccomp? ( sys-libs/libseccomp )"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ # Taken from app-emulation/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+
+ # Setup GOPATH so things build
+ rm -rf .gopath
+ mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
+ ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
+ export GOPATH="${PWD}/.gopath:${PWD}/vendor"
+
+ # build up optional flags
+ local options=( $(usex seccomp "seccomp") )
+
+ emake BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin runc
+}