summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-02-27 23:09:52 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-02-27 23:09:52 +0100
commit9289c0b32921eb6a77af50e065855b86abfc11f3 (patch)
treedeec2ee4d9ffeef2a9b82cfb17a862db0f0813c0 /app-emulation/runc
parentapp-i18n/poedit: remove old (diff)
downloadgentoo-9289c0b32921eb6a77af50e065855b86abfc11f3.tar.gz
gentoo-9289c0b32921eb6a77af50e065855b86abfc11f3.tar.bz2
gentoo-9289c0b32921eb6a77af50e065855b86abfc11f3.zip
app-emulation/runc: Version bump to 1.0.0_rc5
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation/runc')
-rw-r--r--app-emulation/runc/Manifest1
-rw-r--r--app-emulation/runc/runc-1.0.0_rc5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/runc/Manifest b/app-emulation/runc/Manifest
index 04d48733c733..c26949225765 100644
--- a/app-emulation/runc/Manifest
+++ b/app-emulation/runc/Manifest
@@ -1 +1,2 @@
DIST runc-1.0.0_rc4.tar.gz 1090513 BLAKE2B 276303e2085eddd549290e3af1a3af4570d0aef43f66f956267451810b0f0fb77f13ed12fe13b76efcd820fc7e0b46eac370a062f43c8600091a807cb12cf733 SHA512 cc2ae38b96f3f3355d9ba26f7af15c57975276aeaf58dcfe7fe5f0f0411ece8584a7cb51ae7fdd2f4109366f55ac8dfb86f225e26377fe07b685bbc56a2518ed
+DIST runc-1.0.0_rc5.tar.gz 1183902 BLAKE2B 46d0ffd9aa79a6f74b3194fa9e1932390115a43c903ae553acb7749d6be41220874a1ff9bae9706b5fecb9495dd6686c38ee1e9baf6118a14990f142baf6f64d SHA512 714230887ff9706c29b0656c5cdb253698bde6252a23e7f48aa690747fb57abd7884c2da1c4d0e314f9f301c5962417351557d15d986e45fcc336e98069aeac6
diff --git a/app-emulation/runc/runc-1.0.0_rc5.ebuild b/app-emulation/runc/runc-1.0.0_rc5.ebuild
new file mode 100644
index 000000000000..53e421c63abc
--- /dev/null
+++ b/app-emulation/runc/runc-1.0.0_rc5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/opencontainers/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-build golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="v${MY_PV}"
+ RUNC_COMMIT="4fc53a8" # Change this when you update the ebuild
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-build golang-vcs-snapshot
+fi
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://runc.io"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+ambient apparmor hardened +seccomp"
+
+RDEPEND="
+ apparmor? ( sys-libs/libapparmor )
+ seccomp? ( sys-libs/libseccomp )
+ !app-emulation/docker-runc
+"
+
+src_compile() {
+ # Taken from app-emulation/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ROOT}/usr/$(get_libdir)"
+
+ # build up optional flags
+ local options=(
+ $(usex ambient 'ambient')
+ $(usex apparmor 'apparmor')
+ $(usex seccomp 'seccomp')
+ )
+
+ GOPATH="${S}"\
+ emake BUILDTAGS="${options[*]}" \
+ COMMIT="${RUNC_COMMIT}" -C src/${EGO_PN}
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin runc
+ dodoc README.md PRINCIPLES.md
+ popd || die
+}