summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2017-08-09 21:49:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-11 10:53:24 +0200
commit8241fe5096b319e303092ec54197ee3ea01dae79 (patch)
tree7271f4fa9618a0c88da5178d182d44247239a916 /app-emulation/sen/sen-0.5.1.ebuild
parentsys-apps/collectl: Bump version (diff)
downloadgentoo-8241fe5096b319e303092ec54197ee3ea01dae79.tar.gz
gentoo-8241fe5096b319e303092ec54197ee3ea01dae79.tar.bz2
gentoo-8241fe5096b319e303092ec54197ee3ea01dae79.zip
app-emulation/sen: Initial commit
Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5374
Diffstat (limited to 'app-emulation/sen/sen-0.5.1.ebuild')
-rw-r--r--app-emulation/sen/sen-0.5.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emulation/sen/sen-0.5.1.ebuild b/app-emulation/sen/sen-0.5.1.ebuild
new file mode 100644
index 000000000000..e9903c074f08
--- /dev/null
+++ b/app-emulation/sen/sen-0.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminal User Interface for docker engine"
+HOMEPAGE="https://github.com/TomasTomecek/sen"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwidtrees[${PYTHON_USEDEP}]
+ dev-python/docker-py[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc docs/*
+}