summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2020-09-05 11:56:47 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-10 07:14:48 +0200
commit35f46741a6ce045a46b3761ecdd4525252ef5c3d (patch)
treea0030e80b9ab40e2112786838a7bcc1d051e7e7b /app-emulation/sen/sen-0.6.1_p20200905.ebuild
parentdev-util/jenkins-bin: add 2.249.1 (diff)
downloadgentoo-35f46741a6ce045a46b3761ecdd4525252ef5c3d.tar.gz
gentoo-35f46741a6ce045a46b3761ecdd4525252ef5c3d.tar.bz2
gentoo-35f46741a6ce045a46b3761ecdd4525252ef5c3d.zip
app-emulation/sen: Patch bump to 0.6.1_p20200903
Bug: https://bugs.gentoo.org/718214 Package-Manager: Portage-3.0.5, Repoman-2.3.23 Signed-off-by: Nelo-T. Wallus <nelo@wallus.de> Closes: https://github.com/gentoo/gentoo/pull/17423 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-emulation/sen/sen-0.6.1_p20200905.ebuild')
-rw-r--r--app-emulation/sen/sen-0.6.1_p20200905.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/sen/sen-0.6.1_p20200905.ebuild b/app-emulation/sen/sen-0.6.1_p20200905.ebuild
new file mode 100644
index 000000000000..785fd0d41f7d
--- /dev/null
+++ b/app-emulation/sen/sen-0.6.1_p20200905.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+COMMIT="02e5872ee2905861e1da06ab5174e1a3f41f0e0b"
+
+DESCRIPTION="Terminal User Interface for docker engine"
+HOMEPAGE="https://github.com/TomasTomecek/sen"
+SRC_URI="https://github.com/TomasTomecek/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwidtrees[${PYTHON_USEDEP}]
+ dev-python/docker-py[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ )
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}
+
+python_test() {
+ pytest -vv tests || die "pytest failed"
+}