summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-04-23 19:04:13 -0700
committerZac Medico <zmedico@gentoo.org>2020-04-23 19:04:13 -0700
commitf9172477a943d1bd512372f23498354e7040e47b (patch)
treedd3b823b721c87efc04c2b067e951e4f6c6369bb /app-emulation/slirp4netns
parentnet-libs/libslirp: Remove vulnerable version 4.2.0 (diff)
downloadgentoo-f9172477a943d1bd512372f23498354e7040e47b.tar.gz
gentoo-f9172477a943d1bd512372f23498354e7040e47b.tar.bz2
gentoo-f9172477a943d1bd512372f23498354e7040e47b.zip
app-emulation/slirp4netns: Bump to version 1.0.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/slirp4netns')
-rw-r--r--app-emulation/slirp4netns/Manifest1
-rw-r--r--app-emulation/slirp4netns/slirp4netns-1.0.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/slirp4netns/Manifest b/app-emulation/slirp4netns/Manifest
index 8aa5c0f23438..b9377c209a29 100644
--- a/app-emulation/slirp4netns/Manifest
+++ b/app-emulation/slirp4netns/Manifest
@@ -1,2 +1,3 @@
DIST slirp4netns-0.4.3.tar.gz 169895 BLAKE2B a8919ced6d9d68823c79396bc8914d32d157c2da566735a495d68c995c5cfafafba7eb1f761cbe9f82c3291afeae4ac55d00de4c094d5f48e2268d540dfca9e6 SHA512 a3415529486f11cf12c799cabc889dca30fbf64d08818359a285ac67c15fc7926d61105291cd8f2652174747e641e159b5b805a8954fd82f7eb9e35058b23265
DIST slirp4netns-1.0.0.tar.gz 51919 BLAKE2B 9d2d95de80e644981f185a6c243949e55761b25cb908c1ee727f06264d08e794e8228a197e0cc858f81f582d3ddb349c5d6cd2566944c63f41299fb2a5a0d3d2 SHA512 fe0256f0b91647b361999915c6c2b975ee33c437afef3cf490f5e33f582da4db97e360e86654831d7e9b2a8b0d78c91080874a9377247693ac54ffdb60ca6fb9
+DIST slirp4netns-1.0.1.tar.gz 51911 BLAKE2B d125dd2c24fd7a817d2b8f16c6bac66399a4a0f37c49d43541f336e7ff09673bca2d6ed2c62cc856034b8e2f6e11ac1ff3753d3546148e68ddf085e8b9aca354 SHA512 4947e32d88c3c8f1b7b2e94a1e73041a48cc8ddf75ffaf691d44cb6ebeaef5cf0b0abb7a8df8919682dfc854a76d73fc5bdebcf01b3ace97be187068d704bf63
diff --git a/app-emulation/slirp4netns/slirp4netns-1.0.1.ebuild b/app-emulation/slirp4netns/slirp4netns-1.0.1.ebuild
new file mode 100644
index 000000000000..4aaf598fb7e5
--- /dev/null
+++ b/app-emulation/slirp4netns/slirp4netns-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="User-mode networking for unprivileged network namespaces"
+HOMEPAGE="https://github.com/rootless-containers/slirp4netns"
+SRC_URI="https://github.com/rootless-containers/slirp4netns/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2=
+ dev-libs/libpcre:=
+ net-libs/libslirp:=
+ sys-libs/libseccomp:=
+ sys-libs/libcap:="
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RESTRICT="test"
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You need to have the tun kernel module loaded in order to have"
+ elog "slirp4netns working"
+ fi
+}