summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-14 11:32:36 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-14 11:32:36 +0100
commit4ef2778e110e7e9b11cb08845fd532653a3becb0 (patch)
treecbab8e1d34a53486ea3a8190e568edb8ef794829 /app-emulation/softgun
parentsci-physics/pythia: Apply the correct patch in pythia:8 (diff)
downloadgentoo-4ef2778e110e7e9b11cb08845fd532653a3becb0.tar.gz
gentoo-4ef2778e110e7e9b11cb08845fd532653a3becb0.tar.bz2
gentoo-4ef2778e110e7e9b11cb08845fd532653a3becb0.zip
app-emulation/softgun: Port to EAPI 7
* Apply gcc-10 workaround (dead upstream) Closes: https://bugs.gentoo.org/707492 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-emulation/softgun')
-rw-r--r--app-emulation/softgun/softgun-0.22.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-emulation/softgun/softgun-0.22.ebuild b/app-emulation/softgun/softgun-0.22.ebuild
index 15758fcf1687..adba0132e20a 100644
--- a/app-emulation/softgun/softgun-0.22.ebuild
+++ b/app-emulation/softgun/softgun-0.22.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit toolchain-funcs eutils
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="ARM software emulator"
HOMEPAGE="http://softgun.sourceforge.net/"
@@ -12,13 +12,15 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
DEPEND="media-libs/alsa-lib"
-RDEPEND=""
+RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.22-make.patch
+PATCHES=( "${FILESDIR}"/${PN}-0.22-make.patch )
+
+src_configure() {
+ append-cflags -fcommon
+ default
}
src_compile() {