summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-06-28 18:35:14 +0200
committerJames Le Cuirot <chewi@gentoo.org>2020-06-30 23:38:52 +0100
commit9e10dafc520eab176bf01e7f7af0bc0202b8ec09 (patch)
treee18e40783abe09acc89c5d3002f2e6c22bbf5723 /app-emulation/uade/uade-2.13-r1.ebuild
parentapp-emulation/docker-compose: 1.26.1 (diff)
downloadgentoo-9e10dafc520eab176bf01e7f7af0bc0202b8ec09.tar.gz
gentoo-9e10dafc520eab176bf01e7f7af0bc0202b8ec09.tar.bz2
gentoo-9e10dafc520eab176bf01e7f7af0bc0202b8ec09.zip
app-emulation/uade: EAPI7, use HTTPS, fix LICENSE, cleanup
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16477 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation/uade/uade-2.13-r1.ebuild')
-rw-r--r--app-emulation/uade/uade-2.13-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emulation/uade/uade-2.13-r1.ebuild b/app-emulation/uade/uade-2.13-r1.ebuild
new file mode 100644
index 000000000000..c98dd0660e1a
--- /dev/null
+++ b/app-emulation/uade/uade-2.13-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation"
+HOMEPAGE="https://zakalwe.fi/uade"
+SRC_URI="https://zakalwe.fi/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-libs/libao"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog doc/BUGS doc/PLANS )
+
+PATCHES=( "${FILESDIR}"/${P}-configure.patch )
+
+src_configure() {
+ tc-export CC
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --package-prefix="${D}" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-text-scope \
+ --without-xmms \
+ --without-audacious || die
+}
+
+src_install() {
+ default
+ doman doc/uade123.1
+}