summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-24 22:58:34 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-26 12:56:30 -0700
commitbe36252abd3dfee169bf5d7e828a0fa40504051d (patch)
tree7b49df8325876530ba3313fc0e69554d7fa0ebe1 /app-emulation/vagrant/vagrant-2.1.5.ebuild
parentdev-perl/XML-Stream: arm stable, bug #663944 (diff)
downloadgentoo-be36252abd3dfee169bf5d7e828a0fa40504051d.tar.gz
gentoo-be36252abd3dfee169bf5d7e828a0fa40504051d.tar.bz2
gentoo-be36252abd3dfee169bf5d7e828a0fa40504051d.zip
app-emulation/vagrant: version bump to 2.1.15
Cleaned up deps a bit. Closes: https://bugs.gentoo.org/667012 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'app-emulation/vagrant/vagrant-2.1.5.ebuild')
-rw-r--r--app-emulation/vagrant/vagrant-2.1.5.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/app-emulation/vagrant/vagrant-2.1.5.ebuild b/app-emulation/vagrant/vagrant-2.1.5.ebuild
new file mode 100644
index 000000000000..e147c40bcd3f
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.1.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="https://vagrantup.com/"
+SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+virtualbox"
+RESTRICT="test"
+
+RDEPEND="${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/childprocess-0.6.0
+ >=dev-ruby/erubis-2.7.0
+ <dev-ruby/i18n-0.8.0:*
+ >=dev-ruby/listen-3.1.5
+ >=dev-ruby/hashicorp-checkpoint-0.1.5
+ >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
+ >=dev-ruby/net-ssh-5.0.0:*
+ >=dev-ruby/net-sftp-2.1
+ >=dev-ruby/net-scp-1.2.0
+ || ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
+ <dev-ruby/mime-types-3:*
+"
+
+# upstream specifies rake>=12 but it apparently doesn't need something this
+# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
+# is tricky, we specify a lower dependency requirement here. This way, we'll be
+# able to stabilize vagrant sooner.
+ruby_add_bdepend "
+ >=dev-ruby/rake-10.0.0
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
+ -e '/ruby_dep/s/<=/>=/' \
+ -i ${PN}.gemspec || die
+
+ # remove windows-specific gems
+ sed -e '/wdm\|winrm/d' \
+ -i ${PN}.gemspec || die
+
+ # remove bsd-specific gems
+ sed -e '/rb-kqueue/d' \
+ -i ${PN}.gemspec || die
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}-r1.in" > "${PN}" || die
+}
+
+all_ruby_install() {
+ newbashcomp contrib/bash/completion.sh ${PN}
+ all_fakegem_install
+
+ # provide executable similar to upstream:
+ # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ keepdir /var/lib/vagrant
+}