summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/vboxgtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/vboxgtk')
-rw-r--r--app-emulation/vboxgtk/Manifest1
-rw-r--r--app-emulation/vboxgtk/metadata.xml8
-rw-r--r--app-emulation/vboxgtk/vboxgtk-0.8.2-r1.ebuild45
3 files changed, 54 insertions, 0 deletions
diff --git a/app-emulation/vboxgtk/Manifest b/app-emulation/vboxgtk/Manifest
new file mode 100644
index 000000000000..578ed92664fd
--- /dev/null
+++ b/app-emulation/vboxgtk/Manifest
@@ -0,0 +1 @@
+DIST vboxgtk-0.8.2.tar.gz 43717 SHA256 317d7b55cc0c98bf3c1fe294a8fc62668709ae14f12b3bf3b32d5fa33451fe95 SHA512 7326bf3892ec6f7d81614982b1a08ba4bf25ed3c10d327f9f56cad1f1493faf784e2d5324177e3abaea9de29eb5daec49c878b6152b4b3c0301ae640142d8aee WHIRLPOOL b465a9ccf2c582b685fa80cdfc16906768c2ac83c25399959a4a737fa13f0a24711651c5bde8ee980bcfee556dc8c539b167299e8f7e9b2637c35659b544cfd6
diff --git a/app-emulation/vboxgtk/metadata.xml b/app-emulation/vboxgtk/metadata.xml
new file mode 100644
index 000000000000..e96e35b1a37c
--- /dev/null
+++ b/app-emulation/vboxgtk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/app-emulation/vboxgtk/vboxgtk-0.8.2-r1.ebuild b/app-emulation/vboxgtk/vboxgtk-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..8f3c0c08cc90
--- /dev/null
+++ b/app-emulation/vboxgtk/vboxgtk-0.8.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PLOCALES="cs gl"
+inherit gnome2-utils l10n distutils-r1
+
+DESCRIPTION="GTK frontend for VirtualBox"
+HOMEPAGE="http://code.google.com/p/vboxgtk/"
+SRC_URI="http://vboxgtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ || ( >=app-emulation/virtualbox-4.2.0[-headless,python,sdk]
+ >=app-emulation/virtualbox-bin-4.2.0[python] )
+ dev-python/pygobject:3
+ x11-libs/gtk+:3[introspection]"
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+
+DOCS=( AUTHORS README )
+
+python_prepare_all() {
+ rm_locale() { rm -r po/"${1}".po || die "LINGUAS removal failed" ;}
+ l10n_for_each_disabled_locale_do rm_locale
+ distutils-r1_python_prepare_all
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}