summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-03-14 11:34:41 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-03-14 11:39:01 -0500
commit81fe05ab42da764d2bdb39006c212d821f7b4fea (patch)
treec2fd28a1676a2175fa77ef253b31b91c3d6bf62b /app-emulation/virt-manager/virt-manager-9999.ebuild
parentapp-emulation/virt-manager: Version bump to 1.4.1, bug #612450 (diff)
downloadgentoo-81fe05ab42da764d2bdb39006c212d821f7b4fea.tar.gz
gentoo-81fe05ab42da764d2bdb39006c212d821f7b4fea.tar.bz2
gentoo-81fe05ab42da764d2bdb39006c212d821f7b4fea.zip
app-emulation/virt-manager: update live ebuild
- bump to EAPI 6 - remove LINGUAS Package-Manager: Portage-2.3.3, Repoman-2.3.2
Diffstat (limited to 'app-emulation/virt-manager/virt-manager-9999.ebuild')
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index 281d89234741..7e64ce32473c 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1
@@ -12,7 +12,7 @@ DESCRIPTION="A graphical tool for administering virtual machines"
HOMEPAGE="http://virt-manager.org"
if [[ ${PV} = *9999* ]]; then
- inherit git-2
+ inherit git-r3
SRC_URI=""
KEYWORDS=""
EGIT_REPO_URI="https://github.com/virt-manager/virt-manager.git"
@@ -21,13 +21,9 @@ else
KEYWORDS="~amd64 ~x86"
fi
-VM_LINGUAS=( as bg bn_IN bs ca cmn cs da de en_GB es fi fr gu hi hr hu is
- it ja kn ko ml mr ms nb nl or pa pl pt pt_BR ro ru sk sr sr@latin sv ta te
- tr uk vi zh_CN zh_TW )
-
LICENSE="GPL-2"
SLOT="0"
-IUSE="gnome-keyring gtk policykit sasl ${VM_LINGUAS[@]/#/linguas_}"
+IUSE="gnome-keyring gtk policykit sasl"
RDEPEND="!app-emulation/virtinst
dev-python/libvirt-python[${PYTHON_USEDEP}]
@@ -44,7 +40,7 @@ RDEPEND="!app-emulation/virtinst
>=net-libs/gtk-vnc-0.3.8[gtk3,introspection,python,${PYTHON_USEDEP}]
net-misc/spice-gtk[usbredir,gtk3,introspection,sasl?]
net-misc/x11-ssh-askpass
- x11-libs/vte:2.90[introspection]
+ x11-libs/vte:2.91[introspection]
gnome-keyring? ( gnome-base/libgnome-keyring )
policykit? ( sys-auth/polkit[introspection] )
x11-themes/gnome-icon-theme
@@ -57,11 +53,6 @@ DOCS=( README.md NEWS.md )
src_prepare() {
distutils-r1_src_prepare
-
- local lang
- for lang in ${VM_LINGUAS[@]}; do
- use linguas_${lang} || rm -v "po/${lang}.po" || die
- done
}
distutils-r1_python_compile() {