summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-10-09 21:47:24 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-10-09 21:47:24 -0500
commitbe5dc77103cc1f8277bbc319defc519810fb4b12 (patch)
tree5fb8878c0013320ac6d74b5ea56b67023a9f1aef /app-emulation/virt-viewer/virt-viewer-4.0.ebuild
parentsys-fs/zfs: version bump 0.6.5.8 (diff)
downloadgentoo-be5dc77103cc1f8277bbc319defc519810fb4b12.tar.gz
gentoo-be5dc77103cc1f8277bbc319defc519810fb4b12.tar.bz2
gentoo-be5dc77103cc1f8277bbc319defc519810fb4b12.zip
app-emulation/virt-viewer: version bump to 4.0
Thanks to Chris Mayo for the updated ebuild! Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/virt-viewer/virt-viewer-4.0.ebuild')
-rw-r--r--app-emulation/virt-viewer/virt-viewer-4.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/virt-viewer/virt-viewer-4.0.ebuild b/app-emulation/virt-viewer/virt-viewer-4.0.ebuild
new file mode 100644
index 000000000000..98564384f3ff
--- /dev/null
+++ b/app-emulation/virt-viewer/virt-viewer-4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Graphical console client for connecting to virtual machines"
+HOMEPAGE="http://virt-manager.org/"
+SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl +spice +vnc"
+
+RDEPEND=">=app-emulation/libvirt-0.10.0[sasl?]
+ app-emulation/libvirt-glib
+ >=dev-libs/libxml2-2.6
+ x11-libs/gtk+:3
+ spice? ( >=net-misc/spice-gtk-0.31[sasl?,gtk3] )
+ vnc? ( >=net-libs/gtk-vnc-0.5.0[sasl?,gtk3] )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ spice? ( >=app-emulation/spice-protocol-0.12.10 )"
+
+REQUIRED_USE="|| ( spice vnc )"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-update-mimedb \
+ --without-ovirt \
+ $(use_with vnc gtk-vnc) \
+ $(use_with spice spice-gtk)
+}