summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-01 20:32:11 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-07 14:02:10 +0100
commit8bc5ec1e77fcb87badca4cd512640c1a77f0a719 (patch)
tree53fc76ae8822eb78aff8846b96e7a80bcbaf1430 /app-emulation/virt-what/virt-what-1.19.ebuild
parentdev-python/pycryptodome: arm stable wrt bug #671970 (diff)
downloadgentoo-8bc5ec1e77fcb87badca4cd512640c1a77f0a719.tar.gz
gentoo-8bc5ec1e77fcb87badca4cd512640c1a77f0a719.tar.bz2
gentoo-8bc5ec1e77fcb87badca4cd512640c1a77f0a719.zip
app-emulation/virt-what: 1.18 → 1.19
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'app-emulation/virt-what/virt-what-1.19.ebuild')
-rw-r--r--app-emulation/virt-what/virt-what-1.19.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emulation/virt-what/virt-what-1.19.ebuild b/app-emulation/virt-what/virt-what-1.19.ebuild
new file mode 100644
index 000000000000..bbc7f8023ffc
--- /dev/null
+++ b/app-emulation/virt-what/virt-what-1.19.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Detects if the current machine is running in a virtual machine"
+HOMEPAGE="https://people.redhat.com/~rjones/virt-what/"
+SRC_URI="https://people.redhat.com/~rjones/virt-what/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dmi"
+
+DEPEND="dev-lang/perl"
+RDEPEND="app-shells/bash
+ dmi? ( sys-apps/dmidecode )"
+
+src_prepare() {
+ default
+
+ # Pretends to be POSIX sh while it is not
+ sed -e 's:/bin/sh:/bin/bash:' -i virt-what.in || die
+}