summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/virt-what
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/virt-what')
-rw-r--r--app-emulation/virt-what/Manifest1
-rw-r--r--app-emulation/virt-what/metadata.xml12
-rw-r--r--app-emulation/virt-what/virt-what-1.12.ebuild20
3 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/virt-what/Manifest b/app-emulation/virt-what/Manifest
new file mode 100644
index 000000000000..bbdc6cd59f5b
--- /dev/null
+++ b/app-emulation/virt-what/Manifest
@@ -0,0 +1 @@
+DIST virt-what-1.12.tar.gz 147144 SHA256 2592082f5b2caa93d3967b7c275a3afabfe49de9f051fdf0da6ded59e2c11b1c SHA512 629e452419a01b86cd5442c4294b5aea6fc475522d7a350ac8e727b59e63948915c755fe6cae16f7824749059662bb0fbd4557a2aa56c098b407037a35881735 WHIRLPOOL a3f9a519c183950a766fe407f8e814a131e2586d738fa0fdbf341d0755bbf726e58da9cde594a8b7c32b9c27094c442ff95b6d3e5adaf92b57d96710383453d3
diff --git a/app-emulation/virt-what/metadata.xml b/app-emulation/virt-what/metadata.xml
new file mode 100644
index 000000000000..0bc914a7f9ae
--- /dev/null
+++ b/app-emulation/virt-what/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+ <use>
+ <flag name='dmi'>Use <pkg>sys-apps/dmidecode</pkg> to read firmware data</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/app-emulation/virt-what/virt-what-1.12.ebuild b/app-emulation/virt-what/virt-what-1.12.ebuild
new file mode 100644
index 000000000000..f3d981a92713
--- /dev/null
+++ b/app-emulation/virt-what/virt-what-1.12.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Detects if the current machine is running in a virtual machine"
+HOMEPAGE="http://people.redhat.com/~rjones/virt-what/"
+SRC_URI="http://people.redhat.com/~rjones/virt-what/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
+IUSE="dmi"
+
+DEPEND="dev-lang/perl"
+RDEPEND="app-shells/bash
+ dmi? ( sys-apps/dmidecode )"