summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2023-06-29 16:37:35 +0200
committerSam James <sam@gentoo.org>2023-07-02 23:32:56 +0100
commitcd59e8c8dc76f8021aebaa6d7b776c5858358eab (patch)
treed3cd2abbc548944a48bbc93cd191117f3d18045a /app-emulation/virtiofsd/virtiofsd-9999.ebuild
parentdev-perl/Net-OpenSSH: add 0.840.0 (diff)
downloadgentoo-cd59e8c8dc76f8021aebaa6d7b776c5858358eab.tar.gz
gentoo-cd59e8c8dc76f8021aebaa6d7b776c5858358eab.tar.bz2
gentoo-cd59e8c8dc76f8021aebaa6d7b776c5858358eab.zip
app-emulation/virtiofsd: Install 50-qemu-virtiofsd.json
With the old virtiofsd provided by app-emulation/qemu the corresponding JSON file descriptor is installed by QEMU. But with this new rust version, we have to install it ourselves in order for libvirt to pick it up. To avoid conflicts with the file installed by app-emulation/qemu we can install it under a different name. And because smaller number means higher priority let's go with "40-qemu-virtiofsd.json" so that users with <app-emulation/qemu-8.0.0 can benefit from rust version of the daemon (if both are installed). Closes: https://bugs.gentoo.org/909372 Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/virtiofsd/virtiofsd-9999.ebuild')
-rw-r--r--app-emulation/virtiofsd/virtiofsd-9999.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-emulation/virtiofsd/virtiofsd-9999.ebuild b/app-emulation/virtiofsd/virtiofsd-9999.ebuild
index 3352892e3b9a..a609ac7791fa 100644
--- a/app-emulation/virtiofsd/virtiofsd-9999.ebuild
+++ b/app-emulation/virtiofsd/virtiofsd-9999.ebuild
@@ -124,3 +124,15 @@ src_unpack() {
cargo_src_unpack
fi
}
+
+src_install() {
+ cargo_src_install
+
+ # Install 50-qemu-virtiofsd.json but to avoid conflicts with
+ # <app-emulation/qemu-8.0.0 install it under different name. In this case,
+ # smaller number means higher priority, but that's probably what users want
+ # anyway if they install this package on top of app-emulation/qemu.
+ # TODO: remove once old QEMUs are removed from the portage.
+ insinto "/usr/share/qemu/vhost-user"
+ newins "50-qemu-virtiofsd.json" "40-qemu-virtiofsd.json"
+}