summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-04-10 13:03:20 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2017-04-10 13:21:52 -0400
commit0fa7249fa80c15e0b63a08da1fdb3c8f87e08fed (patch)
tree30346e3324dc969b9b9f47a0d851d6f99ac56d26 /app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild
parentapp-emulation/wine-desktop-common: Shared files between variants/slots (diff)
downloadgentoo-0fa7249fa80c15e0b63a08da1fdb3c8f87e08fed.tar.gz
gentoo-0fa7249fa80c15e0b63a08da1fdb3c8f87e08fed.tar.bz2
gentoo-0fa7249fa80c15e0b63a08da1fdb3c8f87e08fed.zip
app-emulation/wine-gecko: Internet Explorer emulaton for Wine
Import from wine-a-holics overlay Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild')
-rw-r--r--app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild b/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild
new file mode 100644
index 000000000000..de77b7295b06
--- /dev/null
+++ b/app-emulation/wine-gecko/wine-gecko-2.47-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN/-/_}
+
+DESCRIPTION="A Mozilla Gecko based version of Internet Explorer for Wine"
+HOMEPAGE="https://winehq.org"
+SRC_URI="
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${MY_PN}-${PV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${MY_PN}-${PV}-x86_64.msi )
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="abi_x86_32 abi_x86_64"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install(){
+ insinto /usr/share/wine/gecko
+ use abi_x86_32 && doins "${DISTDIR}/${MY_PN}-${PV}-x86.msi"
+ use abi_x86_64 && doins "${DISTDIR}/${MY_PN}-${PV}-x86_64.msi"
+}