summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2021-07-31 20:23:09 -0400
committerNick Sarnie <sarnex@gentoo.org>2021-07-31 20:23:09 -0400
commit5f83fbe789a009a317f8b9bb8439cd156ab807eb (patch)
tree840fe33af347fefe7227306dbc29dc4e82f2d259 /app-emulation/wine-mono
parentapp-emulation/wine-gecko: Fix KEYWORDS (diff)
downloadgentoo-5f83fbe789a009a317f8b9bb8439cd156ab807eb.tar.gz
gentoo-5f83fbe789a009a317f8b9bb8439cd156ab807eb.tar.bz2
gentoo-5f83fbe789a009a317f8b9bb8439cd156ab807eb.zip
app-emulation/wine-mono: Sync with ::wine
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/wine-mono')
-rw-r--r--app-emulation/wine-mono/Manifest2
-rw-r--r--app-emulation/wine-mono/wine-mono-6.3.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index 5ef191f0def0..6894124848d7 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -2,3 +2,5 @@ DIST wine-mono-5.1.1-x86.msi 84130304 BLAKE2B 05a5344b59249a758443cf91670eaef71d
DIST wine-mono-5.1.1-x86.tar.xz 44710604 BLAKE2B 162e5c8b12a0384d218ae049c8a948d48fe50ca51212e1c00f11a207f26a759c749d1b8cd416990856358af3d9899670a363d568eda83b66f5e94efc72eea1ff SHA512 9d2e1c42669164bb3c0096ade0dfd465f633436f18246b1a4d169ae0ae2e3b51d8f94d79409cb71a65b878705d5d38e6f4aa155787e340a9294ff22dbe39cf95
DIST wine-mono-6.2.0-x86.msi 87498240 BLAKE2B f7e20876732cbdfc472d5f850b167feceb4e09dd1d14db2d5e81580fb28cb1ec2fc7d1a48a187a0b0d0ad3884c3880a9f3512efdc5ace02795c3158b404a6770 SHA512 99007d7bf3bbdb97babdcc9411a3c9583c261918889e72f785e41cc0638fe4774d81040eebb7d3547ac2609a4684263feefa9e70b662f277ea1717dbd604d3d2
DIST wine-mono-6.2.0-x86.tar.xz 43071332 BLAKE2B f334600697375757c734ff22274665b3bc1cb7495d465e1d209b240b9b2aafdd93f9f246f5415e9f36526bceee6066a13fe01a81d93779dac35687fe0d44f7df SHA512 7e5ed7e4abf88d915d59715b107722135af08bb43e6356f9ae95fdafc539332150a82f85b67d15710ae4ece6c883733bab142f59894f70acd893cac85f6ca905
+DIST wine-mono-6.3.0-x86.msi 86689280 BLAKE2B 5c3cbe92dc055e97fa6dc894659cbd2666bd6a2ae0ee08c998c5326379a205596d89127d22aeabdf73c99aa8e4ade4d5e05663d0a1e1f9f1d322c7c18a4cd4ea SHA512 e71accf7d649c576728a41e9dda5dc9c21e3ebc0330e01be30c1f196bdb2925c5fefb6e9337cc8043f4b42721702dda4dc9224cb7a31e322410f4002d1f84f42
+DIST wine-mono-6.3.0-x86.tar.xz 44392520 BLAKE2B bdaa64005564a134605f924f256a709e40cb713bd1f24f2ac5e82a095e353a81487c74813c88e74ed02905cc23a3bf50e99e908a3536a9671f4920d9093cbe75 SHA512 d39bcbaa65e4299711351516e74d559887b152caa3731cc72bbb23412ed76f5b8cf124c2f46241b677b074277c680120a645f738cdcd840ff60465b20deda3b7
diff --git a/app-emulation/wine-mono/wine-mono-6.3.0.ebuild b/app-emulation/wine-mono/wine-mono-6.3.0.ebuild
new file mode 100644
index 000000000000..b396802d99cc
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-6.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/wine/mono
+ if use shared; then
+ doins -r "${P}"
+ else
+ doins "${DISTDIR}/${P}-x86.msi"
+ fi
+}