summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2021-07-31 20:06:44 -0400
committerNick Sarnie <sarnex@gentoo.org>2021-07-31 20:08:56 -0400
commita4cb52850e63b7f83b7351eff34ae9c3b2233fd6 (patch)
tree0c7bbfef378be56126b5c89a8f00f42d33ec316a /app-emulation/wine-mono
parentapp-emulation/wine-mono: Drop old (diff)
downloadgentoo-a4cb52850e63b7f83b7351eff34ae9c3b2233fd6.tar.gz
gentoo-a4cb52850e63b7f83b7351eff34ae9c3b2233fd6.tar.bz2
gentoo-a4cb52850e63b7f83b7351eff34ae9c3b2233fd6.zip
app-emulation/wine-mono: Sync with ::wine
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/wine-mono')
-rw-r--r--app-emulation/wine-mono/Manifest1
-rw-r--r--app-emulation/wine-mono/metadata.xml3
-rw-r--r--app-emulation/wine-mono/wine-mono-6.2.0.ebuild12
3 files changed, 14 insertions, 2 deletions
diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index 7443097e75ca..4bbaddae8bf9 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -1 +1,2 @@
DIST wine-mono-6.2.0-x86.msi 87498240 BLAKE2B f7e20876732cbdfc472d5f850b167feceb4e09dd1d14db2d5e81580fb28cb1ec2fc7d1a48a187a0b0d0ad3884c3880a9f3512efdc5ace02795c3158b404a6770 SHA512 99007d7bf3bbdb97babdcc9411a3c9583c261918889e72f785e41cc0638fe4774d81040eebb7d3547ac2609a4684263feefa9e70b662f277ea1717dbd604d3d2
+DIST wine-mono-6.2.0-x86.tar.xz 43071332 BLAKE2B f334600697375757c734ff22274665b3bc1cb7495d465e1d209b240b9b2aafdd93f9f246f5415e9f36526bceee6066a13fe01a81d93779dac35687fe0d44f7df SHA512 7e5ed7e4abf88d915d59715b107722135af08bb43e6356f9ae95fdafc539332150a82f85b67d15710ae4ece6c883733bab142f59894f70acd893cac85f6ca905
diff --git a/app-emulation/wine-mono/metadata.xml b/app-emulation/wine-mono/metadata.xml
index a64284bc1ee9..279a9220271e 100644
--- a/app-emulation/wine-mono/metadata.xml
+++ b/app-emulation/wine-mono/metadata.xml
@@ -11,4 +11,7 @@
<upstream>
<remote-id type="github">madewokherd/wine-mono</remote-id>
</upstream>
+ <use>
+ <flag name="shared">Install pre-unpacked files which do not need to be copied into the Wine prefix</flag>
+ </use>
</pkgmetadata>
diff --git a/app-emulation/wine-mono/wine-mono-6.2.0.ebuild b/app-emulation/wine-mono/wine-mono-6.2.0.ebuild
index 0860b6bcb4b4..b396802d99cc 100644
--- a/app-emulation/wine-mono/wine-mono-6.2.0.ebuild
+++ b/app-emulation/wine-mono/wine-mono-6.2.0.ebuild
@@ -5,11 +5,15 @@ EAPI=7
DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
HOMEPAGE="https://www.winehq.org/"
-SRC_URI="https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi"
+SRC_URI="
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+"
LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
SLOT="${PV}"
KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
DEPEND="!!app-emulation/wine:0"
@@ -17,5 +21,9 @@ S="${WORKDIR}"
src_install() {
insinto /usr/share/wine/mono
- doins "${DISTDIR}/${P}-x86.msi"
+ if use shared; then
+ doins -r "${P}"
+ else
+ doins "${DISTDIR}/${P}-x86.msi"
+ fi
}