summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2021-11-22 21:43:46 -0500
committerNick Sarnie <sarnex@gentoo.org>2021-11-22 21:51:02 -0500
commitdf7521d25d089e75e0fbaaccf2dc2cbb33143cae (patch)
tree067b80bc9cacb15008795d880b95576bd3192035 /app-emulation/wine-mono
parentsci-mathematics/nauty: new upstream version 2.7.3. (diff)
downloadgentoo-df7521d25d089e75e0fbaaccf2dc2cbb33143cae.tar.gz
gentoo-df7521d25d089e75e0fbaaccf2dc2cbb33143cae.tar.bz2
gentoo-df7521d25d089e75e0fbaaccf2dc2cbb33143cae.zip
app-emulation/wine-mono: Sync with ::wine
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/wine-mono')
-rw-r--r--app-emulation/wine-mono/Manifest2
-rw-r--r--app-emulation/wine-mono/wine-mono-7.0.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index 6f3b8ee20da6..0779de22f8c6 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -6,3 +6,5 @@ DIST wine-mono-6.3.0-x86.msi 86689280 BLAKE2B 5c3cbe92dc055e97fa6dc894659cbd2666
DIST wine-mono-6.3.0-x86.tar.xz 44392520 BLAKE2B bdaa64005564a134605f924f256a709e40cb713bd1f24f2ac5e82a095e353a81487c74813c88e74ed02905cc23a3bf50e99e908a3536a9671f4920d9093cbe75 SHA512 d39bcbaa65e4299711351516e74d559887b152caa3731cc72bbb23412ed76f5b8cf124c2f46241b677b074277c680120a645f738cdcd840ff60465b20deda3b7
DIST wine-mono-6.4.0-x86.msi 86398976 BLAKE2B d1d553f6115618744bea65d7e88fdf19bfdf677ad5c948d9d598fe461ad668f778e5a8ae2084c584c9d6dae9bee68b85f9837c20016ab82c2401644dcfa06c1a SHA512 5e0eda47bd73b4f1d2d4017c1e6f1d14c9801067e085e9c991532c50454dd22b6594bd05733b4aae8a1010e8b443ff2bdbe70398880ea569142b33e253892f12
DIST wine-mono-6.4.0-x86.tar.xz 44177712 BLAKE2B de08e829ade18be0d0896742aa66f3dd9ab96eb0c994ae164f0fc64fb6306dd278714bbea3cd20d9a04625bc502764a875d57fa530489a22d4f69cbe20696cfb SHA512 4e793ab755e3a4b5ff1dd0354756a9635482db6fd98fc90cb710edfd5e1f553e124913e323681bc82827655a5b1056d33c1f9632b5ea1e3e72d547cd780f2d2e
+DIST wine-mono-7.0.0-x86.msi 86433280 BLAKE2B 9d164bf10f9c790a1f518624321a77965800742c84677a6372cd57b1f51bdd16a2d61ee85f868e84be9b07d4c3f5a7afa770e98637f698c2337c42d42890cf58 SHA512 d7af2a68c3b48cab93ddd489f674ab9064d69d5ca0b6c91e58713dd0408af9fb1ff82ef8847d91645d96df40cd5526c6735d621064a3598166ab5f51d1e0d076
+DIST wine-mono-7.0.0-x86.tar.xz 45085800 BLAKE2B 504c57acce486c19a54bf33cdb4b9444c07a58a7f56ced0c93178886a91fa5d94a61f6e26aa885f3e3a2cceb2ff792f01006a4b16fa5bb88c3d25ddff02fefd7 SHA512 a3977563c5eb6418eaeda25e5b39bd2ef1faf305d514979211e049280c4577718ca48c8566e527b97a58fc465b310dd600093a616102573e12e8985794d828a6
diff --git a/app-emulation/wine-mono/wine-mono-7.0.0.ebuild b/app-emulation/wine-mono/wine-mono-7.0.0.ebuild
new file mode 100644
index 000000000000..b396802d99cc
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-7.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/wine/mono
+ if use shared; then
+ doins -r "${P}"
+ else
+ doins "${DISTDIR}/${P}-x86.msi"
+ fi
+}