summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-12 21:49:19 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-13 00:17:46 -0400
commit708a61dd148c0664366c35b8a471f84bc8e92cfc (patch)
treed449c4491b941da1d326c0929939eb9d4218a0e8 /app-emulation/wine-staging
parentapp-emulation/wine-vanilla: fix clang + USE=-llvm-libunwind build (diff)
downloadgentoo-708a61dd148c0664366c35b8a471f84bc8e92cfc.tar.gz
gentoo-708a61dd148c0664366c35b8a471f84bc8e92cfc.tar.bz2
gentoo-708a61dd148c0664366c35b8a471f84bc8e92cfc.zip
app-emulation/wine-staging: fix clang + USE=-llvm-libunwind build
_Unwind_Find_FDE doesn't exist in libunwind but does in gcc's rtlib, clang instead expects it from llvm-libunwind which leads to undefined references even with USE=-unwind. Messy but add extra guards around it. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-staging')
-rw-r--r--app-emulation/wine-staging/files/wine-staging-7.17-llvm-libunwind.patch9
-rw-r--r--app-emulation/wine-staging/files/wine-staging-7.17-unwind.patch40
-rw-r--r--app-emulation/wine-staging/wine-staging-7.17.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild2
4 files changed, 42 insertions, 11 deletions
diff --git a/app-emulation/wine-staging/files/wine-staging-7.17-llvm-libunwind.patch b/app-emulation/wine-staging/files/wine-staging-7.17-llvm-libunwind.patch
deleted file mode 100644
index a7f8772ab5c4..000000000000
--- a/app-emulation/wine-staging/files/wine-staging-7.17-llvm-libunwind.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-Note the dodgy _CONFIG_H_ check can be removed when >=llvm-libunwind-15
-(which adds _VERSION) is well established: https://reviews.llvm.org/D121015
---- a/dlls/ntdll/unix/signal_x86_64.c
-+++ b/dlls/ntdll/unix/signal_x86_64.c
-@@ -1458,3 +1458,3 @@
-
--#ifdef __APPLE__
-+#if defined(__APPLE__) || defined(_LIBUNWIND_VERSION) || defined(____LIBUNWIND_CONFIG_H__)
- rc = unw_getcontext( &unw_context );
diff --git a/app-emulation/wine-staging/files/wine-staging-7.17-unwind.patch b/app-emulation/wine-staging/files/wine-staging-7.17-unwind.patch
new file mode 100644
index 000000000000..52512ca82968
--- /dev/null
+++ b/app-emulation/wine-staging/files/wine-staging-7.17-unwind.patch
@@ -0,0 +1,40 @@
+Fix build with llvm-libunwind, and also fix for non-llvm libunwind
+when using clang+bfd given clang doesn't have _Unwind_Find_FDE in
+its rtlib and expects it from llvm-libunwind.
+
+The _CONFIG_H_ check is for <llvm-libunwind-15 (adds _VERSION).
+--- a/dlls/ntdll/unix/signal_x86_64.c
++++ b/dlls/ntdll/unix/signal_x86_64.c
+@@ -734,7 +734,9 @@
+ unsigned int cie_offset;
+ };
+
++#if defined(_LIBUNWIND_VERSION) || defined(____LIBUNWIND_CONFIG_H__) || !defined(__clang__)
+ extern const struct dwarf_fde *_Unwind_Find_FDE (void *, struct dwarf_eh_bases *);
++#endif
+
+ static unsigned char dwarf_get_u1( const unsigned char **p )
+ {
+@@ -1456,7 +1458,7 @@
+ unw_proc_info_t info;
+ int rc;
+
+-#ifdef __APPLE__
++#if defined(__APPLE__) || defined(_LIBUNWIND_VERSION) || defined(____LIBUNWIND_CONFIG_H__)
+ rc = unw_getcontext( &unw_context );
+ if (rc == UNW_ESUCCESS)
+ rc = unw_init_local( &cursor, &unw_context );
+@@ -1579,11 +1581,13 @@
+ NTSTATUS CDECL unwind_builtin_dll( ULONG type, DISPATCHER_CONTEXT *dispatch, CONTEXT *context )
+ {
+ struct dwarf_eh_bases bases;
++#if defined(_LIBUNWIND_VERSION) || defined(____LIBUNWIND_CONFIG_H__) || !defined(__clang__)
+ const struct dwarf_fde *fde = _Unwind_Find_FDE( (void *)(context->Rip - 1), &bases );
+
+ if (fde)
+ return dwarf_virtual_unwind( context->Rip, &dispatch->EstablisherFrame, context, fde,
+ &bases, &dispatch->LanguageHandler, &dispatch->HandlerData );
++#endif
+ #ifdef HAVE_LIBUNWIND
+ return libunwind_virtual_unwind( context->Rip, &dispatch->EstablisherFrame, context,
+ &dispatch->LanguageHandler, &dispatch->HandlerData );
diff --git a/app-emulation/wine-staging/wine-staging-7.17.ebuild b/app-emulation/wine-staging/wine-staging-7.17.ebuild
index 8b3f0ce65d88..945a246e3988 100644
--- a/app-emulation/wine-staging/wine-staging-7.17.ebuild
+++ b/app-emulation/wine-staging/wine-staging-7.17.ebuild
@@ -126,8 +126,8 @@ IDEPEND="app-eselect/eselect-wine"
QA_TEXTRELS="usr/lib/*/wine/i386-unix/*.so" # uses -fno-PIC -Wl,-z,notext
PATCHES=(
- "${FILESDIR}"/${PN}-7.17-llvm-libunwind.patch
"${FILESDIR}"/${PN}-7.17-noexecstack.patch
+ "${FILESDIR}"/${PN}-7.17-unwind.patch
)
pkg_pretend() {
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 8b3f0ce65d88..945a246e3988 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -126,8 +126,8 @@ IDEPEND="app-eselect/eselect-wine"
QA_TEXTRELS="usr/lib/*/wine/i386-unix/*.so" # uses -fno-PIC -Wl,-z,notext
PATCHES=(
- "${FILESDIR}"/${PN}-7.17-llvm-libunwind.patch
"${FILESDIR}"/${PN}-7.17-noexecstack.patch
+ "${FILESDIR}"/${PN}-7.17-unwind.patch
)
pkg_pretend() {