summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-08-26 00:42:40 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-08-26 00:43:16 -0400
commit26512e9ccdcce4f77440d4118061da9fff236caf (patch)
treeb3c86c68c40dc8a9888e3f245e2d98a680b9bb7a /app-emulation/wine/wine-1.6.2.ebuild
parentapp-emulation/wine: add 1.7.50 (diff)
downloadgentoo-26512e9ccdcce4f77440d4118061da9fff236caf.tar.gz
gentoo-26512e9ccdcce4f77440d4118061da9fff236caf.tar.bz2
gentoo-26512e9ccdcce4f77440d4118061da9fff236caf.zip
app-emulation/wine: restrict gcc-5 only for 64-bit wine
Also, improve error message a bit. Gentoo-Bug: 549768 Thanks-to: xpue Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-emulation/wine/wine-1.6.2.ebuild')
-rw-r--r--app-emulation/wine/wine-1.6.2.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-emulation/wine/wine-1.6.2.ebuild b/app-emulation/wine/wine-1.6.2.ebuild
index 3e554f5bb9ab..0deb2a37f888 100644
--- a/app-emulation/wine/wine-1.6.2.ebuild
+++ b/app-emulation/wine/wine-1.6.2.ebuild
@@ -173,6 +173,15 @@ usr/share/applications/wine-winecfg.desktop"
wine_build_environment_check() {
[[ ${MERGE_TYPE} = "binary" ]] && return 0
+ # bug #549768
+ if use abi_x86_64 && [[ $(gcc-major-version) = 5 ]]; then
+ eerror "64-bit wine cannot be built with gcc-5.1 or 5.2 due to compiler bugs;"
+ eerror "you may use gcc-config to select an older compiler version."
+ eerror "See https://bugs.gentoo.org/549768"
+ eerror
+ return 1
+ fi
+
if use abi_x86_64 && [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]]; then
eerror "You need gcc-4.4+ to build 64-bit wine"
eerror