summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-07-11 13:48:13 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-07-11 13:48:55 -0400
commitdd9a77d4bd4929d83b16c7d7ef8a364e254d2378 (patch)
treea23333123291d21282736b7b0bc864f219d20241 /app-emulation/wine/wine-1.8.2-r1.ebuild
parentprofiles/arch/powerpc/ppc32: move quassel qt5 flag back to package.use.mask (diff)
downloadgentoo-dd9a77d4bd4929d83b16c7d7ef8a364e254d2378.tar.gz
gentoo-dd9a77d4bd4929d83b16c7d7ef8a364e254d2378.tar.bz2
gentoo-dd9a77d4bd4929d83b16c7d7ef8a364e254d2378.zip
app-emulation/wine: Fix two QA issues, #588604
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/wine/wine-1.8.2-r1.ebuild')
-rw-r--r--app-emulation/wine/wine-1.8.2-r1.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-emulation/wine/wine-1.8.2-r1.ebuild b/app-emulation/wine/wine-1.8.2-r1.ebuild
index 6d7436a6108a..772d165365dd 100644
--- a/app-emulation/wine/wine-1.8.2-r1.ebuild
+++ b/app-emulation/wine/wine-1.8.2-r1.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.40"
-MV="4.5.6"
+VANILLA_GV="2.40"
+VANILLA_MV="4.5.6"
STAGING_GV="2.40"
STAGING_MV="4.5.6"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -35,10 +35,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -262,7 +262,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -347,7 +350,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {