summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2016-07-09 22:00:23 +0300
committerNP-Hardass <NP-Hardass@gentoo.org>2016-07-09 20:44:53 -0400
commit56d5cef67a5f77e1936f5bb60c8b7bc794ddff5c (patch)
tree5b29396efde58ee0e26efeda139b4d8b89f0a1fa /app-emulation/winetricks/winetricks-20160709.ebuild
parentnet-fs/smbnetfs: depend on libgnome-keyring (diff)
downloadgentoo-56d5cef67a5f77e1936f5bb60c8b7bc794ddff5c.tar.gz
gentoo-56d5cef67a5f77e1936f5bb60c8b7bc794ddff5c.tar.bz2
gentoo-56d5cef67a5f77e1936f5bb60c8b7bc794ddff5c.zip
app-emulation/winetricks: Version bump to 20160709.
Package-Manager: portage-2.3.0 Signed-off-by: NP-Hardass <NP-Hardass@gentoo.org>
Diffstat (limited to 'app-emulation/winetricks/winetricks-20160709.ebuild')
-rw-r--r--app-emulation/winetricks/winetricks-20160709.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/app-emulation/winetricks/winetricks-20160709.ebuild b/app-emulation/winetricks/winetricks-20160709.ebuild
new file mode 100644
index 000000000000..b8aef92710f5
--- /dev/null
+++ b/app-emulation/winetricks/winetricks-20160709.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome2-utils eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Winetricks/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Winetricks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+wtg=winetricks-gentoo-2012.11.24
+
+SRC_URI="${SRC_URI}
+ gtk? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )
+ kde? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )"
+
+DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
+HOMEPAGE="http://winetricks.org http://wiki.winehq.org/winetricks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="gtk kde rar"
+
+DEPEND=""
+RDEPEND="app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ app-emulation/wine
+ net-misc/wget
+ x11-misc/xdg-utils
+ gtk? ( gnome-extra/zenity )
+ kde? ( kde-apps/kdialog )
+ rar? ( app-arch/unrar )"
+
+# Uses a non-standard "Wine" category, which is provided by app-emulation/wine; #451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+
+# Tests require network access and run Wine, which is unreliable from a portage environment.
+RESTRICT="test"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
+ else
+ default
+ fi
+}
+
+src_install() {
+ default
+ if use gtk || use kde; then
+ cd "${WORKDIR}/${wtg}" || die
+ domenu winetricks.desktop
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins wine-winetricks.svg
+ fi
+}
+
+pkg_preinst() {
+ if use gtk || use kde; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}