summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-25 15:20:50 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-25 15:20:50 +0200
commit4bbae9322ea97f3db31b511accfc8ea243f2cbc2 (patch)
tree6d377953108a433ab9bef7f9df8fc27f39851e7e /app-emulation/xcpc
parentapp-text/vilistextum: remove unused patches (diff)
downloadgentoo-4bbae9322ea97f3db31b511accfc8ea243f2cbc2.tar.gz
gentoo-4bbae9322ea97f3db31b511accfc8ea243f2cbc2.tar.bz2
gentoo-4bbae9322ea97f3db31b511accfc8ea243f2cbc2.zip
app-emulation/xcpc: Bump to 0.36.0
* Now with GTK 3 support Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-emulation/xcpc')
-rw-r--r--app-emulation/xcpc/Manifest1
-rw-r--r--app-emulation/xcpc/xcpc-0.36.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emulation/xcpc/Manifest b/app-emulation/xcpc/Manifest
index b4ebc547667a..8a47bbf9ec44 100644
--- a/app-emulation/xcpc/Manifest
+++ b/app-emulation/xcpc/Manifest
@@ -1 +1,2 @@
DIST xcpc-0.35.0.tar.gz 1058202 BLAKE2B f5002fcc69a078cd05c05a981522edd15900295136419157f997effd81a89f7452cec335bbdba0be3b303bdc8f8537d4aac255ee7cf4e9ec53cc1143413ad1c1 SHA512 667db6db33f2cab85647960edb5b1c200037bfc464527a60eca85c31549360226893853a38d98e657bde111a28aca47d9741b16b13284759b66cb6213da27458
+DIST xcpc-0.36.0.tar.gz 1092363 BLAKE2B 4f799aefa417f6e2c04c0c3760c4d15b10b863f528e5051cfe90ea5a8ccb4c3f83fb592bbf510a351c02dc42a2a2a42f9fcb33b65a5e2dd997feeb5ea22f5342 SHA512 0cf6e718daf6b7db981aa607036e57eddb2ae18665393b0a691d8fd6978278ca077ae45a205eae93b6107b83d5d219702018f1afcda84ae7b83a7b6d68a68cba
diff --git a/app-emulation/xcpc/xcpc-0.36.0.ebuild b/app-emulation/xcpc/xcpc-0.36.0.ebuild
new file mode 100644
index 000000000000..add31369b9f2
--- /dev/null
+++ b/app-emulation/xcpc/xcpc-0.36.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="XCPC is a portable Amstrad CPC 464/664/6128 emulator written in C."
+HOMEPAGE="http://www.xcpc-emulator.net/doku.php/index"
+SRC_URI="https://bitbucket.org/ponceto/xcpc/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --disable-athena \
+ --disable-motif2 \
+ --with-x11-toolkit=gtk3
+}