summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-12-26 15:06:33 +0800
committerIan Delaney <idella4@gentoo.org>2015-12-27 09:22:51 +0800
commit4e6cfc899a24f2d6a6ed9af72abede0973f87053 (patch)
treebbdb2b04dd0587fc2b4a2fecfb6f0bab6b06be84 /app-emulation/xen
parentnet-dns/dnscrypt-proxy: ease of use improvements. (diff)
downloadgentoo-4e6cfc899a24f2d6a6ed9af72abede0973f87053.tar.gz
gentoo-4e6cfc899a24f2d6a6ed9af72abede0973f87053.tar.bz2
gentoo-4e6cfc899a24f2d6a6ed9af72abede0973f87053.zip
app-emulation/xen: add msg in pkg_postinst to all vns. 4.5 4.5 re xen-syms
Prompt from user in bug #552424 to make install of /boot/xen-syms optional, done by informing user via msg in pkg_postinst to do this using INSTALL_MASK Gentoo bug: #552424 Package-Manager: portage-2.2.24
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/xen-4.5.2-r2.ebuild5
-rw-r--r--app-emulation/xen/xen-4.5.2-r3.ebuild4
-rw-r--r--app-emulation/xen/xen-4.6.0-r3.ebuild4
-rw-r--r--app-emulation/xen/xen-4.6.0-r4.ebuild4
4 files changed, 17 insertions, 0 deletions
diff --git a/app-emulation/xen/xen-4.5.2-r2.ebuild b/app-emulation/xen/xen-4.5.2-r2.ebuild
index 07af8f9be985..d703dcf280c1 100644
--- a/app-emulation/xen/xen-4.5.2-r2.ebuild
+++ b/app-emulation/xen/xen-4.5.2-r2.ebuild
@@ -177,9 +177,14 @@ src_install() {
}
pkg_postinst() {
+ local msg="INSTALL_MASK=/boot/xen-syms"
elog "Official Xen Guide and the unoffical wiki page:"
elog " https://wiki.gentoo.org/wiki/Xen"
elog " http://en.gentoo-wiki.com/wiki/Xen/"
use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+
+ elog "You can optionally block the installation of /boot/xen-syms by an entry"
+ elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
+ elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
}
diff --git a/app-emulation/xen/xen-4.5.2-r3.ebuild b/app-emulation/xen/xen-4.5.2-r3.ebuild
index 2bd75da2cb0c..434306c66456 100644
--- a/app-emulation/xen/xen-4.5.2-r3.ebuild
+++ b/app-emulation/xen/xen-4.5.2-r3.ebuild
@@ -185,4 +185,8 @@ pkg_postinst() {
elog " http://en.gentoo-wiki.com/wiki/Xen/"
use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+
+ elog "You can optionally block the installation of /boot/xen-syms by an entry"
+ elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
+ elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
}
diff --git a/app-emulation/xen/xen-4.6.0-r3.ebuild b/app-emulation/xen/xen-4.6.0-r3.ebuild
index 4ca1a84356e7..7ff1d1daea5f 100644
--- a/app-emulation/xen/xen-4.6.0-r3.ebuild
+++ b/app-emulation/xen/xen-4.6.0-r3.ebuild
@@ -182,4 +182,8 @@ pkg_postinst() {
elog " http://en.gentoo-wiki.com/wiki/Xen/"
use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+
+ elog "You can optionally block the installation of /boot/xen-syms by an entry"
+ elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
+ elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
}
diff --git a/app-emulation/xen/xen-4.6.0-r4.ebuild b/app-emulation/xen/xen-4.6.0-r4.ebuild
index c1c7fa0dbbc7..277e71a12752 100644
--- a/app-emulation/xen/xen-4.6.0-r4.ebuild
+++ b/app-emulation/xen/xen-4.6.0-r4.ebuild
@@ -183,4 +183,8 @@ pkg_postinst() {
elog " http://en.gentoo-wiki.com/wiki/Xen/"
use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+
+ elog "You can optionally block the installation of /boot/xen-syms by an entry"
+ elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
+ elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
}