summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-08 00:15:11 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-08 00:30:22 -0500
commit01290bcb86f9942a6a68eee0f364c5e8c83d02e8 (patch)
treeb06da74a32907ccb4d4e9ccb3211185db0aaf545 /app-emulation
parentdev-util/maturin: add 0.14.5 (diff)
downloadgentoo-01290bcb86f9942a6a68eee0f364c5e8c83d02e8.tar.gz
gentoo-01290bcb86f9942a6a68eee0f364c5e8c83d02e8.tar.bz2
gentoo-01290bcb86f9942a6a68eee0f364c5e8c83d02e8.zip
app-emulation/vkd3d: add 1.6
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vkd3d/Manifest1
-rw-r--r--app-emulation/vkd3d/vkd3d-1.6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index 6701414214c5..7e6b76791c9c 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1 +1,2 @@
DIST vkd3d-1.5.tar.xz 776260 BLAKE2B c021dd03b120f3ad8da61147a12f9d581a85aaf458f34308f06a648167562adedd670444473cbc5ca66c1ff6242b2add21396bbc5cce308c39482451aa5b45e5 SHA512 69ec33bef28334a9a55da34621c71623843995279fb5267cc56228cd343c8cf292deb848596e6f850dfee6d07cc35206fc034fc4ce2a911652a9c42c032cdc08
+DIST vkd3d-1.6.tar.xz 785844 BLAKE2B 6dff7aaad966b378809c87969a54568b943c52bec072fa03becdb40c4ff098168924c363e642aa42049f4468ff75013175fb847cc213278a4e10ea54e906a288 SHA512 0f640c1b139f5ccce8e6d1986d1439c2b0d14e7ac533216d2408dbeee07172eee51549311db22464c2ae89070ca15191aaffd967749676586984561ce1d4b38f
diff --git a/app-emulation/vkd3d/vkd3d-1.6.ebuild b/app-emulation/vkd3d/vkd3d-1.6.ebuild
new file mode 100644
index 000000000000..f0e863b89b11
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://gitlab.winehq.org/wine/vkd3d/"
+SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses spirv-tools"
+RESTRICT="test" #838655
+
+RDEPEND="
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ ncurses? ( sys-libs/ncurses:= )
+ spirv-tools? ( dev-util/spirv-tools[${MULTILIB_USEDEP}] )"
+DEPEND="
+ ${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+multilib_src_configure() {
+ local conf=(
+ $(multilib_native_use_with ncurses)
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ --without-xcb
+ )
+
+ ECONF_SOURCE=${S} econf "${conf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+}