summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-04 02:23:44 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-04 02:23:44 -0600
commit0b2cd033144f3bacbc59bae67e50cde8762d95b7 (patch)
tree0b88ed03831cd96b2ff14b2e99f8b426c20bd7d4 /app-emulation
parentapp-admin/setools: update remove gui patch for 4.1.0 (diff)
downloadgentoo-0b2cd033144f3bacbc59bae67e50cde8762d95b7.tar.gz
gentoo-0b2cd033144f3bacbc59bae67e50cde8762d95b7.tar.bz2
gentoo-0b2cd033144f3bacbc59bae67e50cde8762d95b7.zip
app-emulation/diskimage-builder: bup
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-1.27.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 8c94bc9916e6..53e14ac3ff6d 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-1.26.1.tar.gz 260140 SHA256 dd842a364124a59aaa3751fe178f8799c39e29badbc69d1459d2ed35b9042660 SHA512 698c97b7e016a87c2acd83d27400bd009e8148bb76efc737fae3344aa2c860fdf4060f1608eaa38566c24fa68c5fdbf51559ab64f9d9ef26d0adbe3a1b69325f WHIRLPOOL 83e86a6b5a1629041465be971657968fbdad3377ba9c3bb60ce29b2dd658165541f6e3b5a67eaa13727221e0a44032aafb26b30e042453e2a4c4e085cb26f3da
+DIST diskimage-builder-1.27.0.tar.gz 264590 SHA256 108e6fa41cbab88a018e43b19f5706b20a984b94131d6451876eedc26a26a892 SHA512 63e98c95452f9ddb9ae21f208b7dc840a9a10a02e9dee8d313cac531854b706f7662ea7b907f38a72c58d6ecdead324782d4cbda32fb7a4861b8c4bef9412a56 WHIRLPOOL 586b62729a5577a0ed804c7f457297e0624d1e491ab82ee95c29443ba46d5769814fded9ae88e2b6f7e2ec8d69b208851f24f26f04667717055944d296ccdb9f
diff --git a/app-emulation/diskimage-builder/diskimage-builder-1.27.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-1.27.0.ebuild
new file mode 100644
index 000000000000..a74c2ce3e7a7
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-1.27.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ dev-python/dib-utils[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools"