summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-12-01 11:23:16 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-12-01 11:24:42 -0600
commit0e72626383eaef525fb52a481d3498b710ce9c6d (patch)
tree1f1509ffb54b503f1d52672ea34d989981f2a6c8 /app-emulation
parentdev-python/aodhclient: bup (diff)
downloadgentoo-0e72626383eaef525fb52a481d3498b710ce9c6d.tar.gz
gentoo-0e72626383eaef525fb52a481d3498b710ce9c6d.tar.bz2
gentoo-0e72626383eaef525fb52a481d3498b710ce9c6d.zip
app-emulation/diskimage-builder: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-1.24.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 70f07b31d0b4..c0c312afa0d5 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-1.23.0.tar.gz 255659 SHA256 c235f459f4a52bf0cff134bb6921d29cdf7b87a4427d070e97e16c4b486fb66d SHA512 18d420759df167762c8b41249c94243081ffcf5312727dfc882964c9957752acadd6c526ef34fc49dcf9539b15852542f51f0d83630d27d67fc1c82efa144708 WHIRLPOOL bdd5ce22ae37f96420d9faae40a3cbcfa0d89ff1698f911759b2d79bfb7f867bee4fd0d827a14c1d825969c2bac6996d108cf9427fac5615de7c3527c268c8ee
+DIST diskimage-builder-1.24.0.tar.gz 256522 SHA256 e5236e0be1d07e0111bceae344bfe6f9dd8b0ed9eba64240e218ecc70b9a7b03 SHA512 27e99142e3d951c2137bf53b16298cc9aacfb5167e9fb4572e735e36b555628262c730570b177ea65565f27afce76c0fb8fdee97c9aa7a2346dfdbae1909fd30 WHIRLPOOL 95f77d78b2d723ec9bdcff190d6e583a0ea6963104126ca146221cf53974137d675e795133659dcd55477645cc2c7c7e8734acd8029f903e98130efd196f16a8
diff --git a/app-emulation/diskimage-builder/diskimage-builder-1.24.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-1.24.0.ebuild
new file mode 100644
index 000000000000..4ea1d4d847b2
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-1.24.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ dev-python/dib-utils[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools"