summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-16 10:50:20 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-16 10:50:20 -0600
commit0f32a766f7d26f8b2cd771d52af91093e2f0c2fc (patch)
tree503add7e91ac5d0a3b62d4e0f011fee6402fc196 /app-emulation
parentapp-admin/ansible: 2.8.8 and 2.9.3 (diff)
downloadgentoo-0f32a766f7d26f8b2cd771d52af91093e2f0c2fc.tar.gz
gentoo-0f32a766f7d26f8b2cd771d52af91093e2f0c2fc.tar.bz2
gentoo-0f32a766f7d26f8b2cd771d52af91093e2f0c2fc.zip
app-emulation/diskimage-builder: 2.33.0 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.33.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 090171eacaed..b1e1fd4d518f 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-2.32.0.tar.gz 435328 BLAKE2B 78f306430819d94045e3b8c424cdf7a0fee9a306a317e44cd363d53bbbcd1af1f06731b83b63e490bb8ad3903630daf84a544878b87d6c7f377786778229f276 SHA512 357b56aba979cabd7a857d6646412893361c05a83e4260d1ef468de1d6fb0fbc2582ab8bf37428c56a52fafcf708b86be470f2c885008b10368bc92a2b679a09
+DIST diskimage-builder-2.33.0.tar.gz 434041 BLAKE2B 16d14c68e7a54b785426516ecced4adb53b4e84f36d36846732ef7c4823644375373249ceacd1371e39262ebc9050f2f86184718dc3fb17b44eaa20f561410c0 SHA512 125bdcc0a2d4249918485115c49482746e4f86cb7883d3689afd4288a0d18ca97bcb669b811034ccb159879520172ca37bd9f9d7ba4ea509f788be0f3cf2259b
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.33.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.33.0.ebuild
new file mode 100644
index 000000000000..17a0c622b03c
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.33.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"