summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2019-03-17 06:50:06 +0100
committerMatthias Maier <tamiko@gentoo.org>2019-03-17 01:53:11 -0500
commit1a88084e8baffbe1b8fbe4d62c52ddc90d1a9e88 (patch)
tree4d24df5cc83bb7eaff5699ec1b77ef8f5a3b5a4b /app-emulation
parentapp-emulation/libvirt-9999: Rebase libvirt-5.1.0-do-not-use-sysconf.patch (diff)
downloadgentoo-1a88084e8baffbe1b8fbe4d62c52ddc90d1a9e88.tar.gz
gentoo-1a88084e8baffbe1b8fbe4d62c52ddc90d1a9e88.tar.bz2
gentoo-1a88084e8baffbe1b8fbe4d62c52ddc90d1a9e88.zip
app-emulation/libvirt-9999: Update hash generation algorithm
I've noticed that bootstrap is run twice. This is because the first time it is run in src_prepare() and there some hash is computed so later when src_configre() gets its word it'll find everything prepared. Well, in the upstream commit of 6d53255377b50b7e412350d079 the hash was changed therefore src_configure() did not find the expected hash and thus re-ran the bootstrap script. Signed-off-by: Michal Privoznik <mprivozn@redhat.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index ad8ef5b0f12d..d297b556e5b8 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -226,8 +226,9 @@ src_prepare() {
# bug #377279
./bootstrap || die "bootstrap failed"
(
- git submodule status | sed 's/^[ +-]//;s/ .*//'
- git hash-object bootstrap.conf
+ git submodule status .gnulib | awk '{ print $1 }'
+ git hash-object bootstrap.conf
+ git ls-tree -d HEAD gnulib/local | awk '{ print $3 }'
) >.git-module-status
fi