summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-12-18 09:36:58 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-12-18 09:36:58 +0000
commit1abc2b91998835018f7191a3e4d2b7232f878030 (patch)
tree6fc9d525abd0781c4082af8a4cf816b48d4a1e94 /app-emulation
parentapp-emulation/fs-uae-launcher: Version bump to 3.1.64 (diff)
downloadgentoo-1abc2b91998835018f7191a3e4d2b7232f878030.tar.gz
gentoo-1abc2b91998835018f7191a3e4d2b7232f878030.tar.bz2
gentoo-1abc2b91998835018f7191a3e4d2b7232f878030.zip
app-emulation/fs-uae-launcher: Drop old 3.1.26
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/fs-uae-launcher/Manifest1
-rw-r--r--app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.26.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/app-emulation/fs-uae-launcher/Manifest b/app-emulation/fs-uae-launcher/Manifest
index 7eaa0cb17a39..7bfd8becebc9 100644
--- a/app-emulation/fs-uae-launcher/Manifest
+++ b/app-emulation/fs-uae-launcher/Manifest
@@ -1,3 +1,2 @@
-DIST fs-uae-launcher-3.1.26.tar.gz 9656516 BLAKE2B 1b8d12ef91631dedf412976e81529ac7138b7f688ad6ae1ad55bfd3625590ee00aab89d229d2aa64eec577d291a6e634362c557428534c355fdb39e878f40253 SHA512 0e4e542bebfe2d8f862005c016fe70319dd6c5e1e413be9b0ce0421bb95253ba6eb92337989cc86210094b9b02a6ad86da4725f1a65d50673703fa6c6cb58f37
DIST fs-uae-launcher-3.1.63.tar.xz 7718940 BLAKE2B e1e6102ce6f3e0a5b3f7429ac5894a50b42f2ee26d3b8bf4fec5b39fa199a28d12ebd056ac0c372ce38f78c820dc0c3dec4c4af0918f3a7e5f4b05f944791afb SHA512 d363512c4930f0a245d5333bb5324264244ffc0eb3a39e4ec419cb4861ca9bf5e1f2084405b7f8757f86f0ed9754dbbbbe0aab3391b04898a7d3dc2621346849
DIST fs-uae-launcher-3.1.64.tar.xz 7719268 BLAKE2B 7753006e40e11d557f9cca90296b189638b832b8c2caebceb3fd5aa0393d3b1236ef2d47b176a900d26ab37012198afeb1549da92ba0570eb9b61df42c896550 SHA512 2f7c485f7707595a847130ebbaad3cf1fe9dc11149744bad2683b1b912a53830b687c0aa5ce97dc95a883182ef51020cc02fa434eac903752530f3780342090a
diff --git a/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.26.ebuild b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.26.ebuild
deleted file mode 100644
index ec2ffc2cc226..000000000000
--- a/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.26.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8,9} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1 xdg
-
-DESCRIPTION="PyQt5-based launcher for FS-UAE"
-HOMEPAGE="https://fs-uae.net/"
-SRC_URI="https://github.com/FrodeSolheim/fs-uae-launcher/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
-IUSE="lha"
-RESTRICT="test" # The test files are just boilerplate.
-
-RDEPEND="
- app-emulation/fs-uae
- $(python_gen_cond_dep '
- dev-python/PyQt5[${PYTHON_USEDEP},declarative,gui,network,opengl,widgets]
- dev-python/pyopengl[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- lha? ( dev-python/python-lhafile[${PYTHON_USEDEP}] )
- ')
-"
-
-BDEPEND="
- sys-devel/gettext
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.0.0-ROMs.patch
-)
-
-src_prepare() {
- default
- python bootstrap
-
- # Unbundle OpenGL library. Keep oyoyo IRC library because upstream
- # is long dead and it's not worth packaging separately.
- rm -r OpenGL/ || die
- sed -i -r "/OpenGL/d" setup.py || die
-}
-
-python_compile_all() {
- emake
-}
-
-python_install() {
- local dir=${EPREFIX}/usr/share/${PN}
- distutils-r1_python_install --install-lib="${dir}" --install-scripts="${dir}"
-}
-
-python_install_all() {
- dosym ../share/${PN}/${PN} /usr/bin/${PN}
- emake install-data DESTDIR="${D}" prefix="${EPREFIX}"/usr
- mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
-}
-
-pkg_postinst() {
- elog "Some important information:"
- elog
- ewarn " - Do not use QtCurve, it will crash PyQt5!"
- elog
- elog " - By default, FS-UAE creates its directories under Documents/FS-UAE."
- elog " If your Documents directory is not configured according to the XDG"
- elog " user diretory spec, ~/FS-UAE will be used as a fallback."
- elog
- elog " - You can override this by putting the path to the desired base"
- elog " directory in a special config file. The config file will be read"
- elog " from ~/.config/fs-uae/base-dir by both FS-UAE and FS-UAE Launcher"
- elog " if it exists."
- elog
- elog " Alternatively, you can start FS-UAE and/or FS-UAE Launcher with"
- elog " --base-dir=/path/to/desired/dir"
-}